CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5

Critical 9.8 Published Updated

Attackers can bypass localhost restrictions using decimal IP encoding to access internal services in concrete5.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-22958?

CVE-2021-22958 is a critical server-side request forgery vulnerability in Concretecms Concrete Cms, published on 7 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A Server-Side Request Forgery vulnerability was found in concrete5 < 8.5.5 that allowed a decimal notation encoded IP address to bypass the limitations in place for localhost allowing interaction with local services. Impact can vary depending on services exposed.CVSSv2.0 AV:A/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N

Weakness: CWE-918

Which versions are affected by CVE-2021-22958?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions8.5.5
concrete5/concrete5 PackagistAll versions8.5.5

Products include Concretecms Concrete Cms.

How do I fix CVE-2021-22958?

Upgrade concrete5/concrete5 to 8.5.5 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2021-22958 being exploited?

There is no known exploitation of CVE-2021-22958 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-284f-f2hw-j2gx.

Is CVE-2021-22958 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free