# CVE-2021-22958: Server-Side Request Forgery vulnerability in concrete5

> Attackers can bypass localhost restrictions using decimal IP encoding to access internal services in concrete5.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-284f-f2hw-j2gx

## What is CVE-2021-22958?

CVE-2021-22958 is a critical server-side request forgery vulnerability in Concretecms Concrete Cms, published on 7 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Server-Side Request Forgery vulnerability was found in concrete5 < 8.5.5 that allowed a decimal notation encoded IP address to bypass the limitations in place for localhost allowing interaction with local services. Impact can vary depending on services exposed.CVSSv2.0 AV:A/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2021-22958?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 8.5.5 |
| `concrete5/concrete5` | Packagist | All versions | 8.5.5 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2021-22958?

Upgrade concrete5/concrete5 to 8.5.5 or later.

## Is CVE-2021-22958 being exploited?

There is no known exploitation of CVE-2021-22958 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)
- [CVE-2022-30117](https://insights.sbomify.com/CVE-2022-30117/): Path traversal in Concrete CMS (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22958 and fix it if it is affected.

What it is: CVE-2021-22958 is a critical server-side request forgery vulnerability in Concretecms Concrete Cms, published on 7 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22958 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.5
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22958/ (Markdown: https://insights.sbomify.com/CVE-2021-22958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22958
- OSV: https://osv.dev/vulnerability/CVE-2021-22958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22958/
Summaries are generated and may contain mistakes; the official description above is the record.
