# CVE-2021-22963: URL Redirection to Untrusted Site ('Open Redirect') in fastify-static

> Remote attackers can redirect users to arbitrary websites in fastify-static when the redirect option is enabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Oct 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p6vg-p826-qp3v

## What is CVE-2021-22963?

CVE-2021-22963 is a medium-severity vulnerability in https://github.com/fastify/fastify-static, published on 14 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A redirect vulnerability in the fastify-static module version < 4.2.4 allows remote attackers to redirect users to arbitrary websites via a double slash // followed by a domain: http://localhost:3000//google.com/%2e%2e.The issue shows up on all the fastify-static applications that set redirect: true option. By default, it is false.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2021-22963?

2 open source packages ship an affected version, including fastify-static. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify-static` | npm | All versions | 4.2.4 |
| `fastify-static` | npm | All versions | 4.2.4 |

Products: Fastify Fastify-Static.

## How do I fix CVE-2021-22963?

Upgrade fastify-static to 4.2.4 or later.

## Is CVE-2021-22963 being exploited?

There is no known exploitation of CVE-2021-22963 in the wild and no public exploit code.

## Other vulnerabilities in https://github.com/fastify/fastify-static

- [CVE-2021-22964](https://insights.sbomify.com/CVE-2021-22964/): DOS and Open Redirect with user input (high 8.8)
- [CVE-2026-18427](https://insights.sbomify.com/CVE-2026-18427/): @fastify/static vulnerable to route guard bypass via non-canonical path segments (high 7.5)
- [CVE-2026-15074](https://insights.sbomify.com/CVE-2026-15074/): @fastify/static vulnerable to route guard bypass via path traversal (high 7.5)
- [CVE-2026-6414](https://insights.sbomify.com/CVE-2026-6414/): @fastify/static vulnerable to route guard bypass via encoded path separators (medium 5.9)
- [CVE-2026-7120](https://insights.sbomify.com/CVE-2026-7120/): @fastify/static vulnerable to Authorization Bypass via Non-Canonical URL Paths (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22963 and fix it if it is affected.

What it is: CVE-2021-22963 is a medium-severity vulnerability in https://github.com/fastify/fastify-static, published on 14 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-22963 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify-static (npm): affected all versions; fixed in 4.2.4
- fastify-static (npm): affected all versions; fixed in 4.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22963/ (Markdown: https://insights.sbomify.com/CVE-2021-22963/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22963
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22963
- OSV: https://osv.dev/vulnerability/CVE-2021-22963

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22963/
Summaries are generated and may contain mistakes; the official description above is the record.
