# CVE-2021-22968: Improper file handling in concrete5/core

> Admins can bypass file extension restrictions to upload and execute malicious code via remote file staging in Concrete CMS.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-g3p2-hfqr-9m25

## What is CVE-2021-22968?

CVE-2021-22968 is a high-severity vulnerability in Concretecms Concrete Cms, published on 19 Nov 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A bypass of adding remote files in Concrete CMS (previously concrete5) File Manager leads to remote code execution in Concrete CMS (concrete5) versions 8.5.6 and below.The external file upload feature stages files in the public directory even if they have disallowed file extensions. They are stored in a directory with a random name, but it's possible to stall the uploads and brute force the directory name. You have to be an admin with the ability to upload files, but this bug gives you the ability to upload restricted file types and execute them depending on server configuration.To fix this, a check for allowed file extensions was added before downloading files to a tmp directory.Concrete CMS Security Team gave this a CVSS v3.1 score of 5.4 AV:N/AC:H/PR:H/UI:R/S:C/C:N/I:H/A:NThis fix is also in Concrete version 9.0.0

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type), CWE-330 (Use of Insufficiently Random Values), CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program)

## Which versions are affected by CVE-2021-22968?

2 open source packages ship an affected version, including concrete5/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/core` | Packagist | All versions | 8.5.7 |
| `concrete5/core` | Packagist | All versions | 8.5.7 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2021-22968?

Upgrade concrete5/core to 8.5.7 or later.

## Is CVE-2021-22968 being exploited?

There is no known exploitation of CVE-2021-22968 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22968 and fix it if it is affected.

What it is: CVE-2021-22968 is a high-severity vulnerability in Concretecms Concrete Cms, published on 19 Nov 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22968 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/core (Packagist): affected all versions; fixed in 8.5.7
- concrete5/core (Packagist): affected all versions; fixed in 8.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22968/ (Markdown: https://insights.sbomify.com/CVE-2021-22968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22968
- OSV: https://osv.dev/vulnerability/CVE-2021-22968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22968/
Summaries are generated and may contain mistakes; the official description above is the record.
