{"answers":{"affected":"1 open source package ship an affected version, including nginx-ingress-controller. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23055 in the wild and no public exploit code.","fix":"Upgrade nginx-ingress-controller to a fixed version for your release line: 1.12.3 or 2.0.3.","what":"CVE-2021-23055 is a medium-severity vulnerability in NGINX Ingress Controller, published on 21 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23055 and fix it if it is affected.\n\nWhat it is: CVE-2021-23055 is a medium-severity vulnerability in NGINX Ingress Controller, published on 21 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23055 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx-ingress-controller (Bitnami): affected from 1.0.0; fixed in 1.12.3, 2.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23055/ (Markdown: https://insights.sbomify.com/CVE-2021-23055/index.md)","id":"CVE-2021-23055","markdown":"https://insights.sbomify.com/CVE-2021-23055/index.md","name":"CVE-2021-23055","record":{"aliases":["BIT-nginx-ingress-controller-2021-23055","GHSA-38cm-wqx5-m22m"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"NGINX Ingress Controller","requires_auth":"low_privilege","summary":"Attackers can bypass command line restrictions to inject arbitrary NGINX configurations via Ingress objects, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_ingress_controller","vendor":"f5"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"On version 2.x before 2.0.3 and 1.x before 1.12.3, the command line restriction that controls snippet use with NGINX Ingress Controller does not apply to Ingress objects. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in NGINX Ingress Controller","id":"CVE-2021-23055","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2021"},"n_packages":1,"n_references":1,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2021-23056"},"packages":[{"ecosystem":"Bitnami","fixed":["1.12.3","2.0.3"],"introduced":["1.0.0","2.0.0"],"last_affected":[],"package":"nginx-ingress-controller","purl":"pkg:bitnami/nginx-ingress-controller","source":"BIT-nginx-ingress-controller-2021-23055"}],"prev":{"headline":"Cross-site scripting in BIG-IP APM","id":"CVE-2021-23054"},"products":["NGINX Ingress Controller"],"published":"2022-04-21","related":[{"cvss_score":8.7,"headline":"NGINX Ingress Controller vulnerability","id":"CVE-2026-55723","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.7,"headline":"NGINX Ingress Controller vulnerability","id":"CVE-2025-14727","kev_date_added":null,"published":"2025-12-17"},{"cvss_score":7.1,"headline":"NGINX Ingress Controller vulnerability","id":"CVE-2026-52865","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":7,"headline":"NGINX ngx_http_hls_module vulnerability CVE-2022-41743","id":"CVE-2022-41743","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":6.5,"headline":"NGINX Ingress Controller vulnerability CVE-2022-30535","id":"CVE-2022-30535","kev_date_added":null,"published":"2022-08-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can bypass command line restrictions to inject arbitrary NGINX configurations via Ingress objects, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2021-23055/"}