# CVE-2021-23055: Security feature bypass in NGINX Ingress Controller

> Attackers can bypass command line restrictions to inject arbitrary NGINX configurations via Ingress objects, potentially leading to code execution.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-nginx-ingress-controller-2021-23055, GHSA-38cm-wqx5-m22m

## What is CVE-2021-23055?

CVE-2021-23055 is a medium-severity vulnerability in NGINX Ingress Controller, published on 21 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

On version 2.x before 2.0.3 and 1.x before 1.12.3, the command line restriction that controls snippet use with NGINX Ingress Controller does not apply to Ingress objects. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2021-23055?

1 open source package ship an affected version, including nginx-ingress-controller. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx-ingress-controller` | Bitnami | From 1.0.0 | 1.12.3, 2.0.3 |

Products: F5 Nginx Ingress Controller.

## How do I fix CVE-2021-23055?

Upgrade nginx-ingress-controller to a fixed version for your release line: 1.12.3 or 2.0.3.

## Is CVE-2021-23055 being exploited?

There is no known exploitation of CVE-2021-23055 in the wild and no public exploit code.

## Other vulnerabilities in NGINX Ingress Controller

- [CVE-2026-55723](https://insights.sbomify.com/CVE-2026-55723/): NGINX Ingress Controller vulnerability (high 8.7)
- [CVE-2025-14727](https://insights.sbomify.com/CVE-2025-14727/): NGINX Ingress Controller vulnerability (high 8.7)
- [CVE-2026-52865](https://insights.sbomify.com/CVE-2026-52865/): NGINX Ingress Controller vulnerability (high 7.1)
- [CVE-2022-41743](https://insights.sbomify.com/CVE-2022-41743/): NGINX ngx_http_hls_module vulnerability CVE-2022-41743 (high 7.0)
- [CVE-2022-30535](https://insights.sbomify.com/CVE-2022-30535/): NGINX Ingress Controller vulnerability CVE-2022-30535 (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23055 and fix it if it is affected.

What it is: CVE-2021-23055 is a medium-severity vulnerability in NGINX Ingress Controller, published on 21 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23055 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx-ingress-controller (Bitnami): affected from 1.0.0; fixed in 1.12.3, 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23055/ (Markdown: https://insights.sbomify.com/CVE-2021-23055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23055
- OSV: https://osv.dev/vulnerability/CVE-2021-23055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23055/
Summaries are generated and may contain mistakes; the official description above is the record.
