{"answers":{"affected":"1 open source package ship an affected version, including joomla. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23129 in the wild and no public exploit code.","fix":"Upgrade joomla to 3.9.25 or later.","what":"CVE-2021-23129 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\\!, published on 4 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-23129 and fix it if it is affected.\n\nWhat it is: CVE-2021-23129 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\\!, published on 4 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-23129 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- joomla (Bitnami): affected from 2.5.0; fixed in 3.9.25\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23129/ (Markdown: https://insights.sbomify.com/CVE-2021-23129/index.md)","id":"CVE-2021-23129","markdown":"https://insights.sbomify.com/CVE-2021-23129/index.md","name":"CVE-2021-23129","record":{"aliases":["BIT-joomla-2021-23129","GHSA-5qp6-q86g-pjq8"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Joomla CMS","requires_auth":"none","summary":"Attackers can inject malicious scripts into alert messages displayed to users, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Joomla","cpe":[{"product":"joomla\\!","vendor":"joomla"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in Joomla! 2.5.0 through 3.9.24. Missing filtering of messages showed to users that could lead to xss issues.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"[20210303] - Core - XSS within alert messages showed to users","id":"CVE-2021-23129","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"joomla:joomla\\!","products":["joomla:joomla\\!"],"type":"xss","year":"2021"},"n_packages":1,"n_references":1,"next":{"headline":"[20210304] - Core - XSS within the feed parser library","id":"CVE-2021-23130"},"packages":[{"ecosystem":"Bitnami","fixed":["3.9.25"],"introduced":["2.5.0"],"last_affected":[],"package":"joomla","purl":"pkg:bitnami/joomla","source":"BIT-joomla-2021-23129"}],"prev":{"headline":"[20210302] - Core - Potential Insecure FOFEncryptRandval","id":"CVE-2021-23128"},"products":["Joomla! CMS"],"published":"2021-03-04","related":[{"cvss_score":9.8,"headline":"PHPMailer Command Injection","id":"CVE-2016-10033","kev_date_added":"2025-07-07","published":"2016-12-30"},{"cvss_score":5.3,"headline":"Joomla! Improper Access Control","id":"CVE-2023-23752","kev_date_added":"2024-01-08","published":"2023-02-16"},{"cvss_score":9.8,"headline":"Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links","id":"CVE-2026-48902","kev_date_added":null,"published":"2026-05-26"},{"cvss_score":9.8,"headline":"[20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package","id":"CVE-2025-25226","kev_date_added":null,"published":"2025-04-08"},{"cvss_score":9.8,"headline":"[20220303] - Core - User row are not bound to a authentication mechanism","id":"CVE-2022-23795","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"[20220305] - Core - Inadequate filtering on the selected Ids","id":"CVE-2022-23797","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"[20220307] - Core - Variable Tampering on JInput $_REQUEST data","id":"CVE-2022-23799","kev_date_added":null,"published":"2022-03-30"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-02-25","vendors":["Joomla! Project"]},"summary":"Attackers can inject malicious scripts into alert messages displayed to users, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2021-23129/"}