# CVE-2021-23266: Improper Output Neutralization for Logs in Crafter Studio


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 16 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-545f-pgp7-fwjf

## What is CVE-2021-23266?

CVE-2021-23266 is a medium-severity vulnerability in Crafter CMS, published on 16 May 2022. 

### Official description

An anonymous user can craft a URL with text that ends up in the log viewer as is. The text can then include textual messages to mislead the administrator.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2021-23266?

2 open source packages ship an affected version, including org.craftercms:craftercms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.craftercms:craftercms` | Maven | From 3.1.0 | 3.1.18 |
| `org.craftercms:craftercms` | Maven | From 3.1.0 | 3.1.18 |

Products: Craftercms Crafter Cms.

## How do I fix CVE-2021-23266?

Upgrade org.craftercms:craftercms to 3.1.18 or later.

## Is CVE-2021-23266 being exploited?

There is no known exploitation of CVE-2021-23266 in the wild and no public exploit code.

## Other vulnerabilities in Crafter CMS

- [CVE-2017-15681](https://insights.sbomify.com/CVE-2017-15681/): Path Traversal in Crafter CMS Crafter Studio (critical 9.8)
- [CVE-2018-19907](https://insights.sbomify.com/CVE-2018-19907/): OS Command Injection in craftercms:crafter-studio (high 8.8)
- [CVE-2017-15683](https://insights.sbomify.com/CVE-2017-15683/): XML injection in Crafter CMS (high 8.6)
- [CVE-2017-15685](https://insights.sbomify.com/CVE-2017-15685/): XML Injection in Crafter CMS Crafter Studio 3.0.1 (high 8.6)
- [CVE-2021-23264](https://insights.sbomify.com/CVE-2021-23264/): Exposure of Resource to Wrong Sphere in org.craftercms:crafter-search (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23266 and fix it if it is affected.

What it is: CVE-2021-23266 is a medium-severity vulnerability in Crafter CMS, published on 16 May 2022. 
Exploitation: There is no known exploitation of CVE-2021-23266 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.craftercms:craftercms (Maven): affected from 3.1.0; fixed in 3.1.18
- org.craftercms:craftercms (Maven): affected from 3.1.0; fixed in 3.1.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23266/ (Markdown: https://insights.sbomify.com/CVE-2021-23266/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23266
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23266
- OSV: https://osv.dev/vulnerability/CVE-2021-23266

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23266/
Summaries are generated and may contain mistakes; the official description above is the record.
