{"answers":{"affected":"2 open source packages ship an affected version, including @graphql-tools/git-loader. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23326 in the wild and no public exploit code.","fix":"Upgrade @graphql-tools/git-loader to 6.2.6 or later.","what":"CVE-2021-23326 is a medium-severity command injection vulnerability in @graphql-tools/git-loader, published on 20 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-23326 and fix it if it is affected.\n\nWhat it is: CVE-2021-23326 is a medium-severity command injection vulnerability in @graphql-tools/git-loader, published on 20 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-23326 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @graphql-tools/git-loader (npm): affected all versions; fixed in 6.2.6\n- @graphql-tools/git-loader (npm): affected all versions; fixed in 6.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23326/ (Markdown: https://insights.sbomify.com/CVE-2021-23326/index.md)","id":"CVE-2021-23326","markdown":"https://insights.sbomify.com/CVE-2021-23326/index.md","name":"CVE-2021-23326","record":{"aliases":["GHSA-vhhw-xjvf-wprr","SNYK-JS-GRAPHQLTOOLSGITLOADER-1062543"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GraphQL tools library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via the git-loader package, requiring developers to upgrade to a patched version.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"graphql-tools","vendor":"the-guild"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"This affects the package @graphql-tools/git-loader before 6.2.6. The use of exec and execSync in packages/loaders/git/src/load-git.ts allows arbitrary command injection.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection","id":"CVE-2021-23326","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":2,"n_references":5,"next":{"headline":"Cross-site Scripting (XSS)","id":"CVE-2021-23327"},"packages":[{"ecosystem":"npm","fixed":["6.2.6"],"introduced":["0"],"last_affected":[],"package":"@graphql-tools/git-loader","purl":null,"source":"GHSA-vhhw-xjvf-wprr"},{"ecosystem":"npm","fixed":["6.2.6"],"introduced":["0"],"last_affected":[],"package":"@graphql-tools/git-loader","purl":"pkg:npm/%40graphql-tools/git-loader","source":"GHSA-vhhw-xjvf-wprr"}],"prev":{"headline":"Security issues in Intelligent Power Protector","id":"CVE-2021-23288"},"products":["@graphql-tools/git-loader"],"published":"2021-01-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via the git-loader package, requiring developers to upgrade to a patched version.","url":"https://insights.sbomify.com/CVE-2021-23326/"}