CVE-2021-23337 Command Injection

High 7.2 Published Updated

Attackers can execute arbitrary commands via the template function in the Lodash JavaScript library, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-23337?

CVE-2021-23337 is a high-severity command injection vulnerability in Netapp Active Iq Unified Manager, published on 15 Feb 2021. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Lodash versions prior to 4.17.21 are vulnerable to Command Injection via the template function.

Weakness: CWE-94

Which versions are affected by CVE-2021-23337?

10 open source packages ship an affected version, including lodash-rails, lodash and lodash-es. It affects 23 products.

PackageAffectedFixed in
lodash-rails RubyGemsAll versions4.17.21
lodash-rails RubyGemsAll versions4.17.21
lodash npmAll versions4.17.21
lodash npmAll versions4.17.21
lodash-es npmAll versions4.17.21
lodash-es npmAll versions4.17.21
4 more packages
lodash-template npmAll versions to 1.0.0None
lodash-template npmAll versions to 1.0.0None
lodash.template npmAll versions to 4.5.0None
lodash.template npmAll versions to 4.5.0None

Products include Lodash Lodash, Netapp Active Iq Unified Manager, Netapp Cloud Manager, Netapp System Manager, Oracle Banking Corporate Lending Process Management, Oracle Banking Credit Facilities Process Management and 17 more.

How do I fix CVE-2021-23337?

Upgrade lodash-rails to 4.17.21 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2021-23337 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-23337 exists.

Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.

All Netapp Active Iq Unified Manager vulnerabilities

Sources

Also known as AZL-44655, CLSA-2026-1775003202, CLSA-2026-1784682758, DEBIAN-CVE-2021-23337, GHSA-35jh-r3h4-6jhm, MINI-c9vg-9mv6-rq7w and 4 more.

Is CVE-2021-23337 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free