{"answers":{"affected":"2 open source packages ship an affected version, including prismjs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23341 in the wild and no public exploit code.","fix":"Upgrade prismjs to 1.23.0 or later.","what":"CVE-2021-23341 is a high-severity denial of service vulnerability in prismjs, published on 18 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23341 and fix it if it is affected.\n\nWhat it is: CVE-2021-23341 is a high-severity denial of service vulnerability in prismjs, published on 18 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23341 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prismjs (npm): affected all versions; fixed in 1.23.0\n- prismjs (npm): affected all versions; fixed in 1.23.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23341/ (Markdown: https://insights.sbomify.com/CVE-2021-23341/index.md)","id":"CVE-2021-23341","markdown":"https://insights.sbomify.com/CVE-2021-23341/index.md","name":"CVE-2021-23341","record":{"aliases":["DEBIAN-CVE-2021-23341","GHSA-h4hr-7fg3-h35w","ROOT-APP-NPM-CVE-2021-23341","UBUNTU-CVE-2021-23341"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript syntax highlighting library","requires_auth":"none","summary":"Attackers can cause a denial of service in applications using PrismJS by exploiting inefficient regular expressions in specific language components.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"prism","vendor":"prismjs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23341","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":6,"next":{"headline":"Cross-site Scripting (XSS)","id":"CVE-2021-23342"},"packages":[{"ecosystem":"npm","fixed":["1.23.0"],"introduced":["0"],"last_affected":[],"package":"prismjs","purl":null,"source":"GHSA-h4hr-7fg3-h35w"},{"ecosystem":"npm","fixed":["1.23.0"],"introduced":["0"],"last_affected":[],"package":"prismjs","purl":"pkg:npm/prismjs","source":"GHSA-h4hr-7fg3-h35w"}],"prev":{"headline":"Local File Inclusion","id":"CVE-2021-23340"},"products":["prismjs"],"published":"2021-02-18","related":[{"cvss_score":7.5,"headline":"Cross-site Scripting in Prism","id":"CVE-2022-23647","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":7.5,"headline":"Inefficient Regular Expression Complexity in prismjs/prism","id":"CVE-2021-3801","kev_date_added":null,"published":"2021-09-15"},{"cvss_score":4.9,"headline":"PrismJS DOM Clobbering vulnerability","id":"CVE-2024-53382","kev_date_added":null,"published":"2025-03-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can cause a denial of service in applications using PrismJS by exploiting inefficient regular expressions in specific language components.","url":"https://insights.sbomify.com/CVE-2021-23341/"}