# CVE-2021-23341: Regular Expression Denial of Service (ReDoS)

> Attackers can cause a denial of service in applications using PrismJS by exploiting inefficient regular expressions in specific language components.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2021
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-23341, GHSA-h4hr-7fg3-h35w, ROOT-APP-NPM-CVE-2021-23341, UBUNTU-CVE-2021-23341

## What is CVE-2021-23341?

CVE-2021-23341 is a high-severity denial of service vulnerability in prismjs, published on 18 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.

## Which versions are affected by CVE-2021-23341?

2 open source packages ship an affected version, including prismjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prismjs` | npm | All versions | 1.23.0 |
| `prismjs` | npm | All versions | 1.23.0 |

Products: Prismjs Prism.

## How do I fix CVE-2021-23341?

Upgrade prismjs to 1.23.0 or later.

## Is CVE-2021-23341 being exploited?

There is no known exploitation of CVE-2021-23341 in the wild and no public exploit code.

## Other vulnerabilities in prismjs

- [CVE-2022-23647](https://insights.sbomify.com/CVE-2022-23647/): Cross-site Scripting in Prism (high 7.5)
- [CVE-2021-3801](https://insights.sbomify.com/CVE-2021-3801/): Inefficient Regular Expression Complexity in prismjs/prism (high 7.5)
- [CVE-2024-53382](https://insights.sbomify.com/CVE-2024-53382/): PrismJS DOM Clobbering vulnerability (medium 4.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23341 and fix it if it is affected.

What it is: CVE-2021-23341 is a high-severity denial of service vulnerability in prismjs, published on 18 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23341 in the wild and no public exploit code.

Affected packages and fixed versions:
- prismjs (npm): affected all versions; fixed in 1.23.0
- prismjs (npm): affected all versions; fixed in 1.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23341/ (Markdown: https://insights.sbomify.com/CVE-2021-23341/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23341
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23341
- OSV: https://osv.dev/vulnerability/CVE-2021-23341

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23341/
Summaries are generated and may contain mistakes; the official description above is the record.
