# CVE-2021-23342: Cross-site Scripting (XSS)

> Attackers can execute malicious JavaScript via unsanitized sidebar HTML or URL bypasses in the docsify documentation library.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L/E:P/RL:U/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-2mm9-c2fx-c7m4

## What is CVE-2021-23342?

CVE-2021-23342 is a high-severity cross-site scripting vulnerability in docsify, published on 19 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package docsify before 4.12.0. It is possible to bypass the remediation done by CVE-2020-7680 and execute malicious JavaScript through the following methods 1) When parsing HTML from remote URLs, the HTML code on the main page is sanitized, but this sanitization is not taking place in the sidebar. 2) The isURL external check can be bypassed by inserting more “////” characters

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-23342?

2 open source packages ship an affected version, including docsify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docsify` | npm | All versions | 4.12.0 |
| `docsify` | npm | All versions | 4.12.0 |

Products: Docsifyjs Docsify.

## How do I fix CVE-2021-23342?

Upgrade docsify to 4.12.0 or later.

## Is CVE-2021-23342 being exploited?

There is no known exploitation of CVE-2021-23342 in the wild and no public exploit code.

## Other vulnerabilities in docsify

- [CVE-2021-30074](https://insights.sbomify.com/CVE-2021-30074/): Docsify vulnerable to cross-site scripting due to mishandled encoding (medium 6.1)
- [CVE-2020-7680](https://insights.sbomify.com/CVE-2020-7680/): Cross-site Scripting in docsify (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23342 and fix it if it is affected.

What it is: CVE-2021-23342 is a high-severity cross-site scripting vulnerability in docsify, published on 19 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23342 in the wild and no public exploit code.

Affected packages and fixed versions:
- docsify (npm): affected all versions; fixed in 4.12.0
- docsify (npm): affected all versions; fixed in 4.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23342/ (Markdown: https://insights.sbomify.com/CVE-2021-23342/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23342
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23342
- OSV: https://osv.dev/vulnerability/CVE-2021-23342

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23342/
Summaries are generated and may contain mistakes; the official description above is the record.
