# CVE-2021-23343: Regular Expression Denial of Service (ReDoS)

> Attackers can cause denial of service in applications using the path-parse library by triggering polynomial time complexity in regular expressions.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-hj48-42vr-x3v9, OESA-2021-1262

## What is CVE-2021-23343?

CVE-2021-23343 is a medium-severity denial of service vulnerability in path-parse, published on 4 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of package path-parse are vulnerable to Regular Expression Denial of Service (ReDoS) via splitDeviceRe, splitTailRe, and splitPathRe regular expressions. ReDoS exhibits polynomial worst-case time complexity.

## Which versions are affected by CVE-2021-23343?

2 open source packages ship an affected version, including path-parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `path-parse` | npm | All versions | 1.0.7 |
| `path-parse` | npm | All versions | 1.0.7 |

Products: Path-Parse Project Path-Parse.

## How do I fix CVE-2021-23343?

Upgrade path-parse to 1.0.7 or later.

## Is CVE-2021-23343 being exploited?

There is no known exploitation of CVE-2021-23343 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23343 and fix it if it is affected.

What it is: CVE-2021-23343 is a medium-severity denial of service vulnerability in path-parse, published on 4 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23343 in the wild and no public exploit code.

Affected packages and fixed versions:
- path-parse (npm): affected all versions; fixed in 1.0.7
- path-parse (npm): affected all versions; fixed in 1.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23343/ (Markdown: https://insights.sbomify.com/CVE-2021-23343/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23343
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23343
- OSV: https://osv.dev/vulnerability/CVE-2021-23343

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23343/
Summaries are generated and may contain mistakes; the official description above is the record.
