# CVE-2021-23347: Cross-site Scripting (XSS)

> Attackers can execute arbitrary JavaScript in user browsers via malicious SSO error messages in Argo CD.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2021
- **Updated:** 17 Sep 2024
- **Also known as:** BIT-argo-cd-2021-23347, GHSA-qq5v-f4c3-395c, GO-2022-0869, SNYK-GOLANG-GITHUBCOMARGOPROJARGOCDCMD-1078291

## What is CVE-2021-23347?

CVE-2021-23347 is a medium-severity cross-site scripting vulnerability in Argoproj Argo Cd, published on 3 Mar 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The package github.com/argoproj/argo-cd/cmd before 1.7.13, from 1.8.0 and before 1.8.6 are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-23347?

6 open source packages ship an affected version, including github.com/argoproj/argo-cd/v2, argo-cd and github.com/argoproj/argo-cd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/argoproj/argo-cd/v2` | Go | All versions | 1.7.13 |
| `github.com/argoproj/argo-cd/v2` | Go | All versions | 1.7.13 |
| `github.com/argoproj/argo-cd/v2` | Go | From 1.8.0 | 1.8.6 |
| `github.com/argoproj/argo-cd/v2` | Go | From 1.8.0 | 1.8.6 |
| `argo-cd` | Bitnami | All versions | 1.7.13, 1.8.6 |
| `github.com/argoproj/argo-cd` | Go | All versions | 1.7.13, 1.8.6 |

Products: Argoproj Argo Cd.

## How do I fix CVE-2021-23347?

Upgrade github.com/argoproj/argo-cd/v2 to a fixed version for your release line: 1.7.13 or 1.8.6.

## Is CVE-2021-23347 being exploited?

There is no known exploitation of CVE-2021-23347 in the wild and no public exploit code.

## Other vulnerabilities in Argoproj Argo Cd

- [CVE-2025-55190](https://insights.sbomify.com/CVE-2025-55190/): Argo CD: Project API Token Exposes Repository Credentials (critical 10.0)
- [CVE-2022-29165](https://insights.sbomify.com/CVE-2022-29165/): Argo CD will blindly trust JWT claims if anonymous access is enabled (critical 10.0)
- [CVE-2023-40029](https://insights.sbomify.com/CVE-2023-40029/): Cluster secret might leak in cluster details page in Argo CD (critical 9.9)
- [CVE-2022-24768](https://insights.sbomify.com/CVE-2022-24768/): Improper access control allows admin privilege escalation in Argo CD (critical 9.9)
- [CVE-2024-21652](https://insights.sbomify.com/CVE-2024-21652/): Argo CD vulnerable to Bypassing of Brute Force Protection via Application Crash and In-Memory Data Loss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23347 and fix it if it is affected.

What it is: CVE-2021-23347 is a medium-severity cross-site scripting vulnerability in Argoproj Argo Cd, published on 3 Mar 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23347 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/argoproj/argo-cd/v2 (Go): affected all versions; fixed in 1.7.13
- github.com/argoproj/argo-cd/v2 (Go): affected all versions; fixed in 1.7.13
- github.com/argoproj/argo-cd/v2 (Go): affected from 1.8.0; fixed in 1.8.6
- github.com/argoproj/argo-cd/v2 (Go): affected from 1.8.0; fixed in 1.8.6
- argo-cd (Bitnami): affected all versions; fixed in 1.7.13, 1.8.6
- github.com/argoproj/argo-cd (Go): affected all versions; fixed in 1.7.13, 1.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23347/ (Markdown: https://insights.sbomify.com/CVE-2021-23347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23347
- OSV: https://osv.dev/vulnerability/CVE-2021-23347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23347/
Summaries are generated and may contain mistakes; the official description above is the record.
