# CVE-2021-23351: Denial of Service (DoS)

> An attacker can cause a denial of service by sending malformed proxy protocol headers that exhaust memory in applications using this Go library.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2021
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-23351, GHSA-fqh4-rh59-xhvf, SNYK-GOLANG-GITHUBCOMPIRESGOPROXYPROTO-1081577, UBUNTU-CVE-2021-23351

## What is CVE-2021-23351?

CVE-2021-23351 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 8 Mar 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The package github.com/pires/go-proxyproto before 0.5.0 are vulnerable to Denial of Service (DoS) via the parseVersion1() function. The reader in this package is a default bufio.Reader wrapping a net.Conn. It will read from the connection until it finds a newline. Since no limits are implemented in the code, a deliberately malformed V1 header could be used to exhaust memory in a server process using this code - and create a DoS. This can be exploited by sending a stream starting with PROXY and continuing to send data (which does not contain a newline) until the target stops acknowledging. The risk here is small, because only trusted sources should be allowed to send proxy protocol headers.

## Which versions are affected by CVE-2021-23351?

2 open source packages ship an affected version, including github.com/pires/go-proxyproto. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pires/go-proxyproto` | Go | All versions | 0.5.0 |
| `github.com/pires/go-proxyproto` | Go | All versions | 0.5.0 |

Products: Fedoraproject Fedora, Go-Proxyproto Project Go-Proxyproto.

## How do I fix CVE-2021-23351?

Upgrade github.com/pires/go-proxyproto to 0.5.0 or later.

## Is CVE-2021-23351 being exploited?

There is no known exploitation of CVE-2021-23351 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23351 and fix it if it is affected.

What it is: CVE-2021-23351 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 8 Mar 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23351 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pires/go-proxyproto (Go): affected all versions; fixed in 0.5.0
- github.com/pires/go-proxyproto (Go): affected all versions; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23351/ (Markdown: https://insights.sbomify.com/CVE-2021-23351/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23351
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23351
- OSV: https://osv.dev/vulnerability/CVE-2021-23351

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23351/
Summaries are generated and may contain mistakes; the official description above is the record.
