{"answers":{"affected":"2 open source packages ship an affected version, including printf. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23354 in the wild and no public exploit code.","fix":"Upgrade printf to 0.6.1 or later.","what":"CVE-2021-23354 is a medium-severity denial of service vulnerability in printf, published on 12 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23354 and fix it if it is affected.\n\nWhat it is: CVE-2021-23354 is a medium-severity denial of service vulnerability in printf, published on 12 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23354 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- printf (npm): affected all versions; fixed in 0.6.1\n- printf (npm): affected all versions; fixed in 0.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23354/ (Markdown: https://insights.sbomify.com/CVE-2021-23354/index.md)","id":"CVE-2021-23354","markdown":"https://insights.sbomify.com/CVE-2021-23354/index.md","name":"CVE-2021-23354","record":{"aliases":["CLSA-2026-1772669616","CLSA-2026-1774311624","GHSA-xfhp-gmh8-r8v2","SNYK-JS-PRINTF-1072096"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript printf library","requires_auth":"none","summary":"An attacker can cause a denial of service by exploiting a vulnerable regular expression in the printf library, leading to excessive CPU consumption.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"printf","vendor":"adaltas"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"The package printf before 0.6.1 are vulnerable to Regular Expression Denial of Service (ReDoS) via the regex string /\\%(?:\\(([\\w_.]+)\\)|([1-9]\\d*)\\$)?([0 +\\-\\]*)(\\*|\\d+)?(\\.)?(\\*|\\d+)?[hlL]?([\\%bscdeEfFgGioOuxX])/g in lib/printf.js. The vulnerable regular expression has cubic worst-case time complexity.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23354","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Arbitrary Command Injection","id":"CVE-2021-23355"},"packages":[{"ecosystem":"npm","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"printf","purl":null,"source":"GHSA-xfhp-gmh8-r8v2"},{"ecosystem":"npm","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"printf","purl":"pkg:npm/printf","source":"GHSA-xfhp-gmh8-r8v2"}],"prev":{"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23353"},"products":["printf"],"published":"2021-03-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can cause a denial of service by exploiting a vulnerable regular expression in the printf library, leading to excessive CPU consumption.","url":"https://insights.sbomify.com/CVE-2021-23354/"}