# CVE-2021-23360: Arbitrary Command Injection


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Mar 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-fc42-h7q4-qp8h, SNYK-JS-KILLPORT-1078535

## What is CVE-2021-23360?

CVE-2021-23360 is a high-severity vulnerability in killport, published on 21 Mar 2021. 

### Official description

This affects the package killport before 1.0.2. If (attacker-controlled) user input is given, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization. Running this PoC will cause the command touch success to be executed, leading to the creation of a file called success.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-23360?

2 open source packages ship an affected version, including killport. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `killport` | npm | All versions | 1.0.2 |
| `killport` | npm | All versions | 1.0.2 |

Products: Killport Project Killport.

## How do I fix CVE-2021-23360?

Upgrade killport to 1.0.2 or later.

## Is CVE-2021-23360 being exploited?

There is no known exploitation of CVE-2021-23360 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23360 and fix it if it is affected.

What it is: CVE-2021-23360 is a high-severity vulnerability in killport, published on 21 Mar 2021. 
Exploitation: There is no known exploitation of CVE-2021-23360 in the wild and no public exploit code.

Affected packages and fixed versions:
- killport (npm): affected all versions; fixed in 1.0.2
- killport (npm): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23360/ (Markdown: https://insights.sbomify.com/CVE-2021-23360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23360
- OSV: https://osv.dev/vulnerability/CVE-2021-23360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23360/
Summaries are generated and may contain mistakes; the official description above is the record.
