# CVE-2021-23364: Regular Expression Denial of Service (ReDoS)

> Attackers can cause denial of service in applications using browserslist by providing specially crafted queries that trigger excessive CPU usage during parsing.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2021
- **Updated:** 17 Sep 2024
- **Also known as:** CLSA-2026-1774311645, CLSA-2026-1777163887, CLSA-2026-1788560456, DEBIAN-CVE-2021-23364, GHSA-w8qv-6jwh-64r5, ROOT-APP-NPM-CVE-2021-23364, UBUNTU-CVE-2021-23364

## What is CVE-2021-23364?

CVE-2021-23364 is a medium-severity denial of service vulnerability in browserslist, published on 28 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package browserslist from 4.0.0 and before 4.16.5 are vulnerable to Regular Expression Denial of Service (ReDoS) during parsing of queries.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-23364?

2 open source packages ship an affected version, including browserslist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `browserslist` | npm | From 4.0.0 | 4.16.5 |
| `browserslist` | npm | From 4.0.0 | 4.16.5 |

Products: Browserslist Project Browserslist.

## How do I fix CVE-2021-23364?

Upgrade browserslist to 4.16.5 or later.

## Is CVE-2021-23364 being exploited?

There is no known exploitation of CVE-2021-23364 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23364 and fix it if it is affected.

What it is: CVE-2021-23364 is a medium-severity denial of service vulnerability in browserslist, published on 28 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23364 in the wild and no public exploit code.

Affected packages and fixed versions:
- browserslist (npm): affected from 4.0.0; fixed in 4.16.5
- browserslist (npm): affected from 4.0.0; fixed in 4.16.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23364/ (Markdown: https://insights.sbomify.com/CVE-2021-23364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23364
- OSV: https://osv.dev/vulnerability/CVE-2021-23364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23364/
Summaries are generated and may contain mistakes; the official description above is the record.
