CVE-2021-23368 Regular Expression Denial of Service (ReDoS)

Medium 5.3 Published Updated

An attacker can cause a denial of service in applications using PostCSS by providing malicious input during source map parsing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-23368?

CVE-2021-23368 is a medium-severity denial of service vulnerability in postcss, published on 12 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Which versions are affected by CVE-2021-23368?

4 open source packages ship an affected version, including postcss. It affects 1 product.

PackageAffectedFixed in
postcss npmFrom 7.0.07.0.36
postcss npmFrom 7.0.07.0.36
postcss npmFrom 8.0.08.2.10
postcss npmFrom 8.0.08.2.10

Products include Postcss Postcss.

How do I fix CVE-2021-23368?

Upgrade postcss to a fixed version for your release line: 7.0.36 or 8.2.10.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-23368 being exploited?

There is no known exploitation of CVE-2021-23368 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2021-23368, GHSA-hwj9-h5mp-3pm3, MINI-cprp-rg48-rhhp, ROOT-APP-NPM-CVE-2021-23368, UBUNTU-CVE-2021-23368.

Is CVE-2021-23368 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free