{"answers":{"affected":"4 open source packages ship an affected version, including postcss. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23368 in the wild and no public exploit code.","fix":"Upgrade postcss to a fixed version for your release line: 7.0.36 or 8.2.10.","what":"CVE-2021-23368 is a medium-severity denial of service vulnerability in postcss, published on 12 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23368 and fix it if it is affected.\n\nWhat it is: CVE-2021-23368 is a medium-severity denial of service vulnerability in postcss, published on 12 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23368 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postcss (npm): affected from 7.0.0; fixed in 7.0.36\n- postcss (npm): affected from 7.0.0; fixed in 7.0.36\n- postcss (npm): affected from 8.0.0; fixed in 8.2.10\n- postcss (npm): affected from 8.0.0; fixed in 8.2.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23368/ (Markdown: https://insights.sbomify.com/CVE-2021-23368/index.md)","id":"CVE-2021-23368","markdown":"https://insights.sbomify.com/CVE-2021-23368/index.md","name":"CVE-2021-23368","record":{"aliases":["DEBIAN-CVE-2021-23368","GHSA-hwj9-h5mp-3pm3","MINI-cprp-rg48-rhhp","ROOT-APP-NPM-CVE-2021-23368","UBUNTU-CVE-2021-23368"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PostCSS library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using PostCSS by providing malicious input during source map parsing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"postcss","vendor":"postcss"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[],"description":"The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23368","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":4,"n_references":10,"next":{"headline":"Remote Code Execution (RCE)","id":"CVE-2021-23369"},"packages":[{"ecosystem":"npm","fixed":["7.0.36"],"introduced":["7.0.0"],"last_affected":[],"package":"postcss","purl":null,"source":"GHSA-hwj9-h5mp-3pm3"},{"ecosystem":"npm","fixed":["7.0.36"],"introduced":["7.0.0"],"last_affected":[],"package":"postcss","purl":"pkg:npm/postcss","source":"GHSA-hwj9-h5mp-3pm3"},{"ecosystem":"npm","fixed":["8.2.10"],"introduced":["8.0.0"],"last_affected":[],"package":"postcss","purl":null,"source":"GHSA-hwj9-h5mp-3pm3"},{"ecosystem":"npm","fixed":["8.2.10"],"introduced":["8.0.0"],"last_affected":[],"package":"postcss","purl":"pkg:npm/postcss","source":"GHSA-hwj9-h5mp-3pm3"}],"prev":{"headline":"Authentication Bypass","id":"CVE-2021-23365"},"products":["postcss"],"published":"2021-04-12","related":[{"cvss_score":7.5,"headline":"PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments","id":"CVE-2026-45623","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":6.3,"headline":"PostCSS: incomplete fix of GHSA-6g55-p6wh-862q — attacker-controlled sourceMappingURL reads arbitrary .map files when `from` is unset","id":"CVE-2026-69153","kev_date_added":null,"published":"2026-08-03"},{"cvss_score":5.3,"headline":"PostCSS line return parsing error","id":"CVE-2023-44270","kev_date_added":null,"published":"2023-09-29"},{"cvss_score":5.3,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23382","kev_date_added":null,"published":"2021-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using PostCSS by providing malicious input during source map parsing.","url":"https://insights.sbomify.com/CVE-2021-23368/"}