# CVE-2021-23369: Remote Code Execution (RCE)

> Attackers can execute arbitrary code by compiling untrusted templates with specific options in the Handlebars library.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2021
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2021-23369, GHSA-f2jv-r9rf-7988, MINI-hp6p-282m-33gc, MINI-vqjr-65xx-8hj6, ROOT-APP-NPM-CVE-2021-23369, UBUNTU-CVE-2021-23369

## What is CVE-2021-23369?

CVE-2021-23369 is a medium-severity code injection vulnerability in handlebars, published on 12 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package handlebars before 4.7.7 are vulnerable to Remote Code Execution (RCE) when selecting certain compiling options to compile templates coming from an untrusted source.

## Which versions are affected by CVE-2021-23369?

8 open source packages ship an affected version, including org.webjars.bowergithub.wycats:handlebars.js, org.webjars.npm:handlebars and org.webjars:handlebars. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.webjars.bowergithub.wycats:handlebars.js` | Maven | All versions | 4.7.7 |
| `org.webjars.bowergithub.wycats:handlebars.js` | Maven | All versions | 4.7.7 |
| `org.webjars.npm:handlebars` | Maven | All versions | 4.7.7 |
| `org.webjars.npm:handlebars` | Maven | All versions | 4.7.7 |
| `org.webjars:handlebars` | Maven | All versions | 4.7.7 |
| `org.webjars:handlebars` | Maven | All versions | 4.7.7 |
| `handlebars` | npm | All versions | 4.7.7 |
| `handlebars` | npm | All versions | 4.7.7 |

Products: Handlebarsjs Handlebars.

## How do I fix CVE-2021-23369?

Upgrade org.webjars.bowergithub.wycats:handlebars.js to 4.7.7 or later.

## Is CVE-2021-23369 being exploited?

There is no known exploitation of CVE-2021-23369 in the wild and no public exploit code.

Public exploit code:

- Handlebars CVE-2021-23369 Vulnerability (github_poc): https://github.com/fazilbaig1/CVE-2021-23369
- https://github.com/dinhvaren/cve-2021-23369 (github_poc): https://github.com/dinhvaren/cve-2021-23369

## Other vulnerabilities in handlebars

- [CVE-2026-33937](https://insights.sbomify.com/CVE-2026-33937/): Handlebars.js has JavaScript Injection via AST Type Confusion (critical 9.8)
- [CVE-2026-33941](https://insights.sbomify.com/CVE-2026-33941/): Handlebars.js has JavaScript Injection in CLI Precompiler via Unescaped Names and Options (high 8.3)
- [CVE-2026-33938](https://insights.sbomify.com/CVE-2026-33938/): Handlebars.js has JavaScript Injection via AST Type Confusion by tampering @partial-block (high 8.1)
- [CVE-2026-33940](https://insights.sbomify.com/CVE-2026-33940/): Handlebars.js has JavaScript Injection via AST Type Confusion when passing an object as dynamic partial (high 8.1)
- [CVE-2019-20920](https://insights.sbomify.com/CVE-2019-20920/): Arbitrary Code Execution in Handlebars (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23369 and fix it if it is affected.

What it is: CVE-2021-23369 is a medium-severity code injection vulnerability in handlebars, published on 12 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23369 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.webjars.bowergithub.wycats:handlebars.js (Maven): affected all versions; fixed in 4.7.7
- org.webjars.bowergithub.wycats:handlebars.js (Maven): affected all versions; fixed in 4.7.7
- org.webjars.npm:handlebars (Maven): affected all versions; fixed in 4.7.7
- org.webjars.npm:handlebars (Maven): affected all versions; fixed in 4.7.7
- org.webjars:handlebars (Maven): affected all versions; fixed in 4.7.7
- org.webjars:handlebars (Maven): affected all versions; fixed in 4.7.7
- handlebars (npm): affected all versions; fixed in 4.7.7
- handlebars (npm): affected all versions; fixed in 4.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23369/ (Markdown: https://insights.sbomify.com/CVE-2021-23369/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23369
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23369
- OSV: https://osv.dev/vulnerability/CVE-2021-23369

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23369/
Summaries are generated and may contain mistakes; the official description above is the record.
