CVE-2021-23382 Regular Expression Denial of Service (ReDoS)

Medium 5.3 Published Updated

An attacker can cause a denial of service in applications using PostCSS by providing specially crafted input that triggers inefficient regular expression processing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-23382?

CVE-2021-23382 is a medium-severity denial of service vulnerability in postcss, published on 26 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The package postcss before 8.2.13 are vulnerable to Regular Expression Denial of Service (ReDoS) via getAnnotationURL() and loadAnnotation() in lib/previous-map.js. The vulnerable regexes are caused mainly by the sub-pattern \/\*\s* sourceMappingURL=(.*).

Weakness: CWE-1333

Which versions are affected by CVE-2021-23382?

4 open source packages ship an affected version, including postcss. It affects 1 product.

PackageAffectedFixed in
postcss npmAll versions7.0.36
postcss npmAll versions7.0.36
postcss npmFrom 8.0.08.2.13
postcss npmFrom 8.0.08.2.13

Products include Postcss Postcss.

How do I fix CVE-2021-23382?

Upgrade postcss to a fixed version for your release line: 7.0.36 or 8.2.13.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-23382 being exploited?

There is no known exploitation of CVE-2021-23382 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2021-23382, GHSA-566m-qj78-rww5, MINI-975m-2v6h-66fp, ROOT-APP-NPM-CVE-2021-23382, UBUNTU-CVE-2021-23382.

Is CVE-2021-23382 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free