# CVE-2021-23382: Regular Expression Denial of Service (ReDoS)

> An attacker can cause a denial of service in applications using PostCSS by providing specially crafted input that triggers inefficient regular expression processing.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Apr 2021
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-23382, GHSA-566m-qj78-rww5, MINI-975m-2v6h-66fp, ROOT-APP-NPM-CVE-2021-23382, UBUNTU-CVE-2021-23382

## What is CVE-2021-23382?

CVE-2021-23382 is a medium-severity denial of service vulnerability in postcss, published on 26 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package postcss before 8.2.13 are vulnerable to Regular Expression Denial of Service (ReDoS) via getAnnotationURL() and loadAnnotation() in lib/previous-map.js. The vulnerable regexes are caused mainly by the sub-pattern \/\*\s* sourceMappingURL=(.*).

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-23382?

4 open source packages ship an affected version, including postcss. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postcss` | npm | All versions | 7.0.36 |
| `postcss` | npm | All versions | 7.0.36 |
| `postcss` | npm | From 8.0.0 | 8.2.13 |
| `postcss` | npm | From 8.0.0 | 8.2.13 |

Products: Postcss Postcss.

## How do I fix CVE-2021-23382?

Upgrade postcss to a fixed version for your release line: 7.0.36 or 8.2.13.

## Is CVE-2021-23382 being exploited?

There is no known exploitation of CVE-2021-23382 in the wild and no public exploit code.

## Other vulnerabilities in postcss

- [CVE-2026-45623](https://insights.sbomify.com/CVE-2026-45623/): PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments (high 7.5)
- [CVE-2026-69153](https://insights.sbomify.com/CVE-2026-69153/): PostCSS: incomplete fix of GHSA-6g55-p6wh-862q — attacker-controlled sourceMappingURL reads arbitrary .map files when `from` is unset (medium 6.3)
- [CVE-2023-44270](https://insights.sbomify.com/CVE-2023-44270/): PostCSS line return parsing error (medium 5.3)
- [CVE-2021-23368](https://insights.sbomify.com/CVE-2021-23368/): Regular Expression Denial of Service (ReDoS) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23382 and fix it if it is affected.

What it is: CVE-2021-23382 is a medium-severity denial of service vulnerability in postcss, published on 26 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23382 in the wild and no public exploit code.

Affected packages and fixed versions:
- postcss (npm): affected all versions; fixed in 7.0.36
- postcss (npm): affected all versions; fixed in 7.0.36
- postcss (npm): affected from 8.0.0; fixed in 8.2.13
- postcss (npm): affected from 8.0.0; fixed in 8.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23382/ (Markdown: https://insights.sbomify.com/CVE-2021-23382/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23382
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23382
- OSV: https://osv.dev/vulnerability/CVE-2021-23382

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23382/
Summaries are generated and may contain mistakes; the official description above is the record.
