{"answers":{"affected":"3 open source packages ship an affected version, including flask-security and Flask-Security. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23385 in the wild and no public exploit code.","fix":"Upgrade flask-security to 5.5.1 or later.","what":"CVE-2021-23385 is a medium-severity vulnerability in Flask-Security, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-23385 and fix it if it is affected.\n\nWhat it is: CVE-2021-23385 is a medium-severity vulnerability in Flask-Security, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-23385 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flask-security (PyPI): affected all versions up to 3.0.0; no fix listed\n- flask-security (PyPI): affected all versions; fixed in 5.5.1\n- Flask-Security (PyPI): affected all versions up to 3.0.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23385/ (Markdown: https://insights.sbomify.com/CVE-2021-23385/index.md)","id":"CVE-2021-23385","markdown":"https://insights.sbomify.com/CVE-2021-23385/index.md","name":"CVE-2021-23385","record":{"aliases":["DEBIAN-CVE-2021-23385","DLA-3545-1","GHSA-cg8c-gc2j-2wf7","MGASA-2023-0105","PYSEC-2026-809","SUSE-SU-2022:3834-1","SUSE-SU-2022:3867-1","UBUNTU-CVE-2021-23385","USN-6792-1"],"analysis":{"component_type":"library","fix_type":"end_of_life","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Flask-Security library","requires_auth":"none","summary":"Attackers can redirect users to malicious sites via bypassed URL validation in Flask-Security when using non-default WSGI configurations.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"flask-security","vendor":"flask-security_project"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P/RL:U/RC:C","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"This affects all versions of package Flask-Security. When using the get_post_logout_redirect and get_post_login_redirect functions, it is possible to bypass URL validation and redirect a user to an arbitrary URL by providing multiple back slashes such as \\\\\\evil.com/path. This vulnerability is only exploitable if an alternative WSGI server other than Werkzeug is used, or the default behaviour of Werkzeug is modified using 'autocorrect_location_header=False. **Note:** Flask-Security is not maintained anymore.","ecosystems":["PyPI","SUSE:Linux Enterprise Module for Basesystem 15 SP3","SUSE:Linux Enterprise Module for Basesystem 15 SP4","openSUSE:Leap 15.3","openSUSE:Leap 15.4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Open Redirect","id":"CVE-2021-23385","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"open_redirect","year":"2021"},"n_packages":9,"n_references":4,"next":{"headline":"Remote Memory Exposure","id":"CVE-2021-23386"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.0.0"],"package":"Flask-Security","purl":null,"source":"GHSA-cg8c-gc2j-2wf7"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.0.0"],"package":"flask-security","purl":"pkg:pypi/flask-security","source":"GHSA-cg8c-gc2j-2wf7"},{"ecosystem":"PyPI","fixed":["5.5.1"],"introduced":["0"],"last_affected":[],"package":"flask-security","purl":"pkg:pypi/flask-security","source":"PYSEC-2026-809"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP3","fixed":["3.4.2-150200.3.6.1"],"introduced":["0"],"last_affected":[],"package":"python-Flask-Security-Too","purl":"pkg:rpm/suse/python-Flask-Security-Too\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP3","source":"SUSE-SU-2022:3867-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP4","fixed":["3.4.2-150200.3.6.1"],"introduced":["0"],"last_affected":[],"package":"python-Flask-Security-Too","purl":"pkg:rpm/suse/python-Flask-Security-Too\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP4","source":"SUSE-SU-2022:3867-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["3.0.0-150100.4.3.1"],"introduced":["0"],"last_affected":[],"package":"python-Flask-Security","purl":"pkg:rpm/opensuse/python-Flask-Security\u0026distro=openSUSE%20Leap%2015.3","source":"SUSE-SU-2022:3834-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["3.4.2-150200.3.6.1"],"introduced":["0"],"last_affected":[],"package":"python-Flask-Security-Too","purl":"pkg:rpm/opensuse/python-Flask-Security-Too\u0026distro=openSUSE%20Leap%2015.3","source":"SUSE-SU-2022:3867-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["3.0.0-150100.4.3.1"],"introduced":["0"],"last_affected":[],"package":"python-Flask-Security","purl":"pkg:rpm/opensuse/python-Flask-Security\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2022:3834-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["3.4.2-150200.3.6.1"],"introduced":["0"],"last_affected":[],"package":"python-Flask-Security-Too","purl":"pkg:rpm/opensuse/python-Flask-Security-Too\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2022:3867-1"}],"prev":{"headline":"Open Redirect","id":"CVE-2021-23384"},"products":["Flask-Security"],"published":"2022-08-02","related":[{"cvss_score":3.1,"headline":"Open Redirect Vulnerability","id":"CVE-2021-32618","kev_date_added":null,"published":"2021-05-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can redirect users to malicious sites via bypassed URL validation in Flask-Security when using non-default WSGI configurations.","url":"https://insights.sbomify.com/CVE-2021-23385/"}