# CVE-2021-23385: Open Redirect

> Attackers can redirect users to malicious sites via bypassed URL validation in Flask-Security when using non-default WSGI configurations.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P/RL:U/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Aug 2022
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-23385, DLA-3545-1, GHSA-cg8c-gc2j-2wf7, MGASA-2023-0105, PYSEC-2026-809, SUSE-SU-2022:3834-1, SUSE-SU-2022:3867-1, UBUNTU-CVE-2021-23385, USN-6792-1

## What is CVE-2021-23385?

CVE-2021-23385 is a medium-severity vulnerability in Flask-Security, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

This affects all versions of package Flask-Security. When using the get_post_logout_redirect and get_post_login_redirect functions, it is possible to bypass URL validation and redirect a user to an arbitrary URL by providing multiple back slashes such as \\\evil.com/path. This vulnerability is only exploitable if an alternative WSGI server other than Werkzeug is used, or the default behaviour of Werkzeug is modified using 'autocorrect_location_header=False. **Note:** Flask-Security is not maintained anymore.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2021-23385?

3 open source packages ship an affected version, including flask-security and Flask-Security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-security` | PyPI | All versions to 3.0.0 | None |
| `flask-security` | PyPI | All versions | 5.5.1 |
| `Flask-Security` | PyPI | All versions to 3.0.0 | None |
| `python-Flask-Security-Too` | SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 3.4.2-150200.3.6.1 |
| `python-Flask-Security-Too` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 3.4.2-150200.3.6.1 |
| `python-Flask-Security` | openSUSE:Leap 15.3 | All versions | 3.0.0-150100.4.3.1 |
| `python-Flask-Security-Too` | openSUSE:Leap 15.3 | All versions | 3.4.2-150200.3.6.1 |
| `python-Flask-Security` | openSUSE:Leap 15.4 | All versions | 3.0.0-150100.4.3.1 |
| `python-Flask-Security-Too` | openSUSE:Leap 15.4 | All versions | 3.4.2-150200.3.6.1 |

Products: Flask-Security Project Flask-Security.

## How do I fix CVE-2021-23385?

Upgrade flask-security to 5.5.1 or later.

## Is CVE-2021-23385 being exploited?

There is no known exploitation of CVE-2021-23385 in the wild and no public exploit code.

## Other vulnerabilities in Flask-Security

- [CVE-2021-32618](https://insights.sbomify.com/CVE-2021-32618/): Open Redirect Vulnerability (low 3.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23385 and fix it if it is affected.

What it is: CVE-2021-23385 is a medium-severity vulnerability in Flask-Security, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-23385 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-security (PyPI): affected all versions up to 3.0.0; no fix listed
- flask-security (PyPI): affected all versions; fixed in 5.5.1
- Flask-Security (PyPI): affected all versions up to 3.0.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23385/ (Markdown: https://insights.sbomify.com/CVE-2021-23385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23385
- OSV: https://osv.dev/vulnerability/CVE-2021-23385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23385/
Summaries are generated and may contain mistakes; the official description above is the record.
