# CVE-2021-23386: Remote Memory Exposure

> Attackers can read internal application memory by sending crafted invalid domain names to applications using the dns-packet library.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2021
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2026-1780447839, GHSA-3wcq-x3mq-6r9p, ROOT-APP-NPM-CVE-2021-23386

## What is CVE-2021-23386?

CVE-2021-23386 is a high-severity vulnerability in dns-packet, published on 20 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

This affects the package dns-packet before 5.2.2. It creates buffers with allocUnsafe and does not always fill them before forming network packets. This can expose internal application memory over unencrypted network when querying crafted invalid domain names.

Weakness: CWE-909 (Missing Initialization of Resource)

## Which versions are affected by CVE-2021-23386?

4 open source packages ship an affected version, including dns-packet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dns-packet` | npm | All versions | 1.3.2 |
| `dns-packet` | npm | All versions | 1.3.2 |
| `dns-packet` | npm | From 2.0.0 | 5.2.2 |
| `dns-packet` | npm | From 2.0.0 | 5.2.2 |

Products: Dns-Packet Project Dns-Packet.

## How do I fix CVE-2021-23386?

Upgrade dns-packet to a fixed version for your release line: 1.3.2 or 5.2.2.

## Is CVE-2021-23386 being exploited?

There is no known exploitation of CVE-2021-23386 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23386 and fix it if it is affected.

What it is: CVE-2021-23386 is a high-severity vulnerability in dns-packet, published on 20 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23386 in the wild and no public exploit code.

Affected packages and fixed versions:
- dns-packet (npm): affected all versions; fixed in 1.3.2
- dns-packet (npm): affected all versions; fixed in 1.3.2
- dns-packet (npm): affected from 2.0.0; fixed in 5.2.2
- dns-packet (npm): affected from 2.0.0; fixed in 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23386/ (Markdown: https://insights.sbomify.com/CVE-2021-23386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23386
- OSV: https://osv.dev/vulnerability/CVE-2021-23386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23386/
Summaries are generated and may contain mistakes; the official description above is the record.
