# CVE-2021-23387: Open Redirect

> An attacker can redirect users to malicious sites via double slashes in URLs, affecting applications using the trailing-slash npm package.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 May 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-rfhr-62xp-2fp2, SNYK-JS-TRAILINGSLASH-1085707

## What is CVE-2021-23387?

CVE-2021-23387 is a medium-severity vulnerability in trailing-slash, published on 24 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The package trailing-slash before 2.0.1 are vulnerable to Open Redirect via the use of trailing double slashes in the URL when accessing the vulnerable endpoint (such as https://example.com//attacker.example/). The vulnerable code is in index.js::createTrailing(), as the web server uses relative URLs instead of absolute URLs.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2021-23387?

2 open source packages ship an affected version, including trailing-slash. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trailing-slash` | npm | All versions | 2.0.1 |
| `trailing-slash` | npm | All versions | 2.0.1 |

Products: Trailing-Slash Project Trailing-Slash.

## How do I fix CVE-2021-23387?

Upgrade trailing-slash to 2.0.1 or later.

## Is CVE-2021-23387 being exploited?

There is no known exploitation of CVE-2021-23387 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23387 and fix it if it is affected.

What it is: CVE-2021-23387 is a medium-severity vulnerability in trailing-slash, published on 24 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-23387 in the wild and no public exploit code.

Affected packages and fixed versions:
- trailing-slash (npm): affected all versions; fixed in 2.0.1
- trailing-slash (npm): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23387/ (Markdown: https://insights.sbomify.com/CVE-2021-23387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23387
- OSV: https://osv.dev/vulnerability/CVE-2021-23387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23387/
Summaries are generated and may contain mistakes; the official description above is the record.
