CVE-2021-23388 Regular Expression Denial of Service (ReDoS)
An attacker can cause a denial of service in applications using the forms library by exploiting a regular expression vulnerability in email validation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-23388?
CVE-2021-23388 is a medium-severity denial of service vulnerability in forms, published on 31 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The package forms before 1.2.1, from 1.3.0 and before 1.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via email validation.
Which versions are affected by CVE-2021-23388?
2 open source packages ship an affected version, including forms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
forms npm | All versions | 1.3.2 |
forms npm | All versions | 1.3.2 |
Products include Forms Project Forms.
How do I fix CVE-2021-23388?
Upgrade forms to 1.3.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-23388 being exploited?
There is no known exploitation of CVE-2021-23388 in the wild and no public exploit code.
Other vulnerabilities in forms
Sources
Also known as GHSA-c56f-grv3-gpfr, SNYK-JS-FORMS-1296389.