{"answers":{"affected":"2 open source packages ship an affected version, including forms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23388 in the wild and no public exploit code.","fix":"Upgrade forms to 1.3.2 or later.","what":"CVE-2021-23388 is a medium-severity denial of service vulnerability in forms, published on 31 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23388 and fix it if it is affected.\n\nWhat it is: CVE-2021-23388 is a medium-severity denial of service vulnerability in forms, published on 31 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23388 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- forms (npm): affected all versions; fixed in 1.3.2\n- forms (npm): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23388/ (Markdown: https://insights.sbomify.com/CVE-2021-23388/index.md)","id":"CVE-2021-23388","markdown":"https://insights.sbomify.com/CVE-2021-23388/index.md","name":"CVE-2021-23388","record":{"aliases":["GHSA-c56f-grv3-gpfr","SNYK-JS-FORMS-1296389"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm forms library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the forms library by exploiting a regular expression vulnerability in email validation.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"forms","vendor":"forms_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[],"description":"The package forms before 1.2.1, from 1.3.0 and before 1.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via email validation.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23388","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Arbitrary Code Execution","id":"CVE-2021-23389"},"packages":[{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"forms","purl":null,"source":"GHSA-c56f-grv3-gpfr"},{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"forms","purl":"pkg:npm/forms","source":"GHSA-c56f-grv3-gpfr"}],"prev":{"headline":"Open Redirect","id":"CVE-2021-23387"},"products":["forms"],"published":"2021-05-31","related":[{"cvss_score":6.1,"headline":"Cross-Site Scripting in forms","id":"CVE-2017-16015","kev_date_added":null,"published":"2018-06-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using the forms library by exploiting a regular expression vulnerability in email validation.","url":"https://insights.sbomify.com/CVE-2021-23388/"}