# CVE-2021-23388: Regular Expression Denial of Service (ReDoS)

> An attacker can cause a denial of service in applications using the forms library by exploiting a regular expression vulnerability in email validation.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-c56f-grv3-gpfr, SNYK-JS-FORMS-1296389

## What is CVE-2021-23388?

CVE-2021-23388 is a medium-severity denial of service vulnerability in forms, published on 31 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package forms before 1.2.1, from 1.3.0 and before 1.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via email validation.

## Which versions are affected by CVE-2021-23388?

2 open source packages ship an affected version, including forms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `forms` | npm | All versions | 1.3.2 |
| `forms` | npm | All versions | 1.3.2 |

Products: Forms Project Forms.

## How do I fix CVE-2021-23388?

Upgrade forms to 1.3.2 or later.

## Is CVE-2021-23388 being exploited?

There is no known exploitation of CVE-2021-23388 in the wild and no public exploit code.

## Other vulnerabilities in forms

- [CVE-2017-16015](https://insights.sbomify.com/CVE-2017-16015/): Cross-Site Scripting in forms (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23388 and fix it if it is affected.

What it is: CVE-2021-23388 is a medium-severity denial of service vulnerability in forms, published on 31 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23388 in the wild and no public exploit code.

Affected packages and fixed versions:
- forms (npm): affected all versions; fixed in 1.3.2
- forms (npm): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23388/ (Markdown: https://insights.sbomify.com/CVE-2021-23388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23388
- OSV: https://osv.dev/vulnerability/CVE-2021-23388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23388/
Summaries are generated and may contain mistakes; the official description above is the record.
