{"answers":{"affected":"2 open source packages ship an affected version, including nodemailer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23400 in the wild and no public exploit code.","fix":"Upgrade nodemailer to 6.6.1 or later.","what":"CVE-2021-23400 is a medium-severity vulnerability in nodemailer, published on 29 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-23400 and fix it if it is affected.\n\nWhat it is: CVE-2021-23400 is a medium-severity vulnerability in nodemailer, published on 29 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-23400 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nodemailer (npm): affected all versions; fixed in 6.6.1\n- nodemailer (npm): affected all versions; fixed in 6.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23400/ (Markdown: https://insights.sbomify.com/CVE-2021-23400/index.md)","id":"CVE-2021-23400","markdown":"https://insights.sbomify.com/CVE-2021-23400/index.md","name":"CVE-2021-23400","record":{"aliases":["DEBIAN-CVE-2021-23400","GHSA-hwqf-gcqm-7353","UBUNTU-CVE-2021-23400"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js email library","requires_auth":"none","summary":"Attackers can inject HTTP headers via unsanitized input in nodemailer, potentially manipulating email delivery or metadata.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"nodemailer","vendor":"nodemailer"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L/E:P","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"The package nodemailer before 6.6.1 are vulnerable to HTTP Header Injection if unsanitized user input that may contain newlines and carriage returns is passed into an address object.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTTP Header Injection","id":"CVE-2021-23400","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Open Redirect","id":"CVE-2021-23401"},"packages":[{"ecosystem":"npm","fixed":["6.6.1"],"introduced":["0"],"last_affected":[],"package":"nodemailer","purl":null,"source":"GHSA-hwqf-gcqm-7353"},{"ecosystem":"npm","fixed":["6.6.1"],"introduced":["0"],"last_affected":[],"package":"nodemailer","purl":"pkg:npm/nodemailer","source":"GHSA-hwqf-gcqm-7353"}],"prev":{"headline":"Arbitrary Command Injection","id":"CVE-2021-23399"},"products":["nodemailer"],"published":"2021-06-29","related":[{"cvss_score":8.6,"headline":"Command Injection","id":"CVE-2020-7769","kev_date_added":null,"published":"2020-11-12"},{"cvss_score":7.5,"headline":"Nodemailer: nodemailer: denial of service via crafted email address header","id":"CVE-2025-14874","kev_date_added":null,"published":"2025-12-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can inject HTTP headers via unsanitized input in nodemailer, potentially manipulating email delivery or metadata.","url":"https://insights.sbomify.com/CVE-2021-23400/"}