{"answers":{"affected":"4 open source packages ship an affected version, including pac-resolver and degenerator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23406 in the wild and no public exploit code.","fix":"Upgrade pac-resolver to 5.0.0 or later.","what":"CVE-2021-23406 is a high-severity code injection vulnerability in pac-resolver, published on 24 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23406 and fix it if it is affected.\n\nWhat it is: CVE-2021-23406 is a high-severity code injection vulnerability in pac-resolver, published on 24 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23406 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pac-resolver (npm): affected all versions; fixed in 5.0.0\n- pac-resolver (npm): affected all versions; fixed in 5.0.0\n- degenerator (npm): affected all versions; fixed in 3.0.1\n- degenerator (npm): affected all versions; fixed in 3.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23406/ (Markdown: https://insights.sbomify.com/CVE-2021-23406/index.md)","id":"CVE-2021-23406","markdown":"https://insights.sbomify.com/CVE-2021-23406/index.md","name":"CVE-2021-23406","record":{"aliases":["CLSA-2026-1790104586","GHSA-9j49-mfvp-vmhm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm pac-resolver library","requires_auth":"none","summary":"Attackers can execute arbitrary code via unsafe PAC file handling in the pac-resolver npm package when processing untrusted input.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"pac-resolver","vendor":"pac-resolver_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[],"description":"This affects the package pac-resolver before 5.0.0. This can occur when used with untrusted input, due to unsafe PAC file handling. **NOTE:** The fix for this vulnerability is applied in the node-degenerator library, a dependency written by the same maintainer.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote Code Execution (RCE)","id":"CVE-2021-23406","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":4,"n_references":5,"next":{"headline":"Directory Traversal","id":"CVE-2021-23407"},"packages":[{"ecosystem":"npm","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"degenerator","purl":null,"source":"GHSA-9j49-mfvp-vmhm"},{"ecosystem":"npm","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"degenerator","purl":"pkg:npm/degenerator","source":"GHSA-9j49-mfvp-vmhm"},{"ecosystem":"npm","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"pac-resolver","purl":null,"source":"GHSA-9j49-mfvp-vmhm"},{"ecosystem":"npm","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"pac-resolver","purl":"pkg:npm/pac-resolver","source":"GHSA-9j49-mfvp-vmhm"}],"prev":{"headline":"SQL Injection","id":"CVE-2021-23405"},"products":["pac-resolver"],"published":"2021-08-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via unsafe PAC file handling in the pac-resolver npm package when processing untrusted input.","url":"https://insights.sbomify.com/CVE-2021-23406/"}