# CVE-2021-23413: Denial of Service (DoS)


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Jul 2021
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-23413, GHSA-jg8v-48h5-wgxg, UBUNTU-CVE-2021-23413

## What is CVE-2021-23413?

CVE-2021-23413 is a medium-severity vulnerability in jszip, published on 25 Jul 2021. 

### Official description

This affects the package jszip before 3.7.0. Crafting a new zip file with filenames set to Object prototype values (e.g __proto__, toString, etc) results in a returned object with a modified prototype instance.

## Which versions are affected by CVE-2021-23413?

4 open source packages ship an affected version, including jszip. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jszip` | npm | All versions | 2.7.0 |
| `jszip` | npm | All versions | 2.7.0 |
| `jszip` | npm | From 3.0.0 | 3.7.0 |
| `jszip` | npm | From 3.0.0 | 3.7.0 |

Products: Jszip Project Jszip.

## How do I fix CVE-2021-23413?

Upgrade jszip to a fixed version for your release line: 2.7.0 or 3.7.0.

## Is CVE-2021-23413 being exploited?

There is no known exploitation of CVE-2021-23413 in the wild and no public exploit code.

## Other vulnerabilities in jszip

- [CVE-2022-48285](https://insights.sbomify.com/CVE-2022-48285/): JSZip contains Path Traversal via loadAsync (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23413 and fix it if it is affected.

What it is: CVE-2021-23413 is a medium-severity vulnerability in jszip, published on 25 Jul 2021. 
Exploitation: There is no known exploitation of CVE-2021-23413 in the wild and no public exploit code.

Affected packages and fixed versions:
- jszip (npm): affected all versions; fixed in 2.7.0
- jszip (npm): affected all versions; fixed in 2.7.0
- jszip (npm): affected from 3.0.0; fixed in 3.7.0
- jszip (npm): affected from 3.0.0; fixed in 3.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23413/ (Markdown: https://insights.sbomify.com/CVE-2021-23413/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23413
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23413
- OSV: https://osv.dev/vulnerability/CVE-2021-23413

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23413/
Summaries are generated and may contain mistakes; the official description above is the record.
