# CVE-2021-23415: Directory Traversal

> Attackers can exploit unsanitized file names to traverse directories and read or modify arbitrary files in elFinder ASP.NET.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:P/RL:O`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-pjxv-w3qj-j8m3, SNYK-DOTNET-ELFINDERASPNET-1315153

## What is CVE-2021-23415?

CVE-2021-23415 is a high-severity path traversal vulnerability in elFinder.AspNet, published on 28 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package elFinder.AspNet before 1.1.1. The user-controlled file name is not properly sanitized before it is used to create a file system path.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-23415?

2 open source packages ship an affected version, including elFinder.AspNet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elFinder.AspNet` | NuGet | All versions | 1.1.1 |
| `elFinder.AspNet` | NuGet | All versions | 1.1.1 |

Products: Elfinder.aspnet Project Elfinder.aspnet.

## How do I fix CVE-2021-23415?

Upgrade elFinder.AspNet to 1.1.1 or later.

## Is CVE-2021-23415 being exploited?

There is no known exploitation of CVE-2021-23415 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23415 and fix it if it is affected.

What it is: CVE-2021-23415 is a high-severity path traversal vulnerability in elFinder.AspNet, published on 28 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23415 in the wild and no public exploit code.

Affected packages and fixed versions:
- elFinder.AspNet (NuGet): affected all versions; fixed in 1.1.1
- elFinder.AspNet (NuGet): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23415/ (Markdown: https://insights.sbomify.com/CVE-2021-23415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23415
- OSV: https://osv.dev/vulnerability/CVE-2021-23415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23415/
Summaries are generated and may contain mistakes; the official description above is the record.
