# CVE-2021-23418: XML External Entity (XXE) Injection

> An attacker can exploit XML External Entity injection in Glances to read sensitive data or cause denial of service.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jul 2021
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-23418, GHSA-r2mj-8wgq-73m6, PYSEC-2021-115, SNYK-PYTHON-GLANCES-1311807, UBUNTU-CVE-2021-23418, USN-5187-1

## What is CVE-2021-23418?

CVE-2021-23418 is a medium-severity vulnerability in Glances, published on 29 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2021-23418?

3 open source packages ship an affected version, including glances and Glances. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 3.2.1 |
| `glances` | PyPI | All versions | 3.2.1 |
| `Glances` | PyPI | All versions | 3.2.1 |

Products: Glances Project Glances.

## How do I fix CVE-2021-23418?

Upgrade glances to 3.2.1 or later.

## Is CVE-2021-23418 being exploited?

There is no known exploitation of CVE-2021-23418 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23418 and fix it if it is affected.

What it is: CVE-2021-23418 is a medium-severity vulnerability in Glances, published on 29 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-23418 in the wild and no public exploit code.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 3.2.1
- glances (PyPI): affected all versions; fixed in 3.2.1
- Glances (PyPI): affected all versions; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23418/ (Markdown: https://insights.sbomify.com/CVE-2021-23418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23418
- OSV: https://osv.dev/vulnerability/CVE-2021-23418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23418/
Summaries are generated and may contain mistakes; the official description above is the record.
