{"answers":{"affected":"4 open source packages ship an affected version, including codeception/codeception. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23420 in the wild and no public exploit code.","fix":"Upgrade codeception/codeception to a fixed version for your release line: 3.1.3 or 4.1.22.","what":"CVE-2021-23420 is a high-severity unsafe deserialization vulnerability in codeception/codeception, published on 11 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23420 and fix it if it is affected.\n\nWhat it is: CVE-2021-23420 is a high-severity unsafe deserialization vulnerability in codeception/codeception, published on 11 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23420 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeception/codeception (Packagist): affected all versions; fixed in 3.1.3\n- codeception/codeception (Packagist): affected all versions; fixed in 3.1.3\n- codeception/codeception (Packagist): affected from 4.0.0; fixed in 4.1.22\n- codeception/codeception (Packagist): affected from 4.0.0; fixed in 4.1.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23420/ (Markdown: https://insights.sbomify.com/CVE-2021-23420/index.md)","id":"CVE-2021-23420","markdown":"https://insights.sbomify.com/CVE-2021-23420/index.md","name":"CVE-2021-23420","record":{"aliases":["GHSA-4574-qv3w-fcmg","SNYK-PHP-CODECEPTIONCODECEPTION-1324585"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP testing library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via unsafe deserialization in the RunProcess class of the Codeception PHP testing library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"codeception","vendor":"codeception"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L/E:F/RL:O/RC:C","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"This affects the package codeception/codeception from 4.0.0 and before 4.1.22, before 3.1.3. The RunProcess class can be leveraged as a gadget to run arbitrary commands on a system that is deserializing user input without validation.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deserialization of Untrusted Data","id":"CVE-2021-23420","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2021"},"n_packages":4,"n_references":4,"next":{"headline":"Prototype Pollution","id":"CVE-2021-23421"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"codeception/codeception","purl":null,"source":"GHSA-4574-qv3w-fcmg"},{"ecosystem":"Packagist","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"codeception/codeception","purl":"pkg:composer/codeception/codeception","source":"GHSA-4574-qv3w-fcmg"},{"ecosystem":"Packagist","fixed":["4.1.22"],"introduced":["4.0.0"],"last_affected":[],"package":"codeception/codeception","purl":null,"source":"GHSA-4574-qv3w-fcmg"},{"ecosystem":"Packagist","fixed":["4.1.22"],"introduced":["4.0.0"],"last_affected":[],"package":"codeception/codeception","purl":"pkg:composer/codeception/codeception","source":"GHSA-4574-qv3w-fcmg"}],"prev":{"headline":"Prototype Pollution","id":"CVE-2021-23419"},"products":["codeception/codeception"],"published":"2021-08-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via unsafe deserialization in the RunProcess class of the Codeception PHP testing library.","url":"https://insights.sbomify.com/CVE-2021-23420/"}