# CVE-2021-23420: Deserialization of Untrusted Data

> Attackers can execute arbitrary commands via unsafe deserialization in the RunProcess class of the Codeception PHP testing library.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L/E:F/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4574-qv3w-fcmg, SNYK-PHP-CODECEPTIONCODECEPTION-1324585

## What is CVE-2021-23420?

CVE-2021-23420 is a high-severity unsafe deserialization vulnerability in codeception/codeception, published on 11 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package codeception/codeception from 4.0.0 and before 4.1.22, before 3.1.3. The RunProcess class can be leveraged as a gadget to run arbitrary commands on a system that is deserializing user input without validation.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-23420?

4 open source packages ship an affected version, including codeception/codeception. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeception/codeception` | Packagist | All versions | 3.1.3 |
| `codeception/codeception` | Packagist | All versions | 3.1.3 |
| `codeception/codeception` | Packagist | From 4.0.0 | 4.1.22 |
| `codeception/codeception` | Packagist | From 4.0.0 | 4.1.22 |

Products: Codeception Codeception.

## How do I fix CVE-2021-23420?

Upgrade codeception/codeception to a fixed version for your release line: 3.1.3 or 4.1.22.

## Is CVE-2021-23420 being exploited?

There is no known exploitation of CVE-2021-23420 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23420 and fix it if it is affected.

What it is: CVE-2021-23420 is a high-severity unsafe deserialization vulnerability in codeception/codeception, published on 11 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23420 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeception/codeception (Packagist): affected all versions; fixed in 3.1.3
- codeception/codeception (Packagist): affected all versions; fixed in 3.1.3
- codeception/codeception (Packagist): affected from 4.0.0; fixed in 4.1.22
- codeception/codeception (Packagist): affected from 4.0.0; fixed in 4.1.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23420/ (Markdown: https://insights.sbomify.com/CVE-2021-23420/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23420
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23420
- OSV: https://osv.dev/vulnerability/CVE-2021-23420

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23420/
Summaries are generated and may contain mistakes; the official description above is the record.
