{"answers":{"affected":"3 open source packages ship an affected version, including bikeshed. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23423 in the wild and no public exploit code.","fix":"Upgrade bikeshed to 3.0.0 or later.","what":"CVE-2021-23423 is a medium-severity path traversal vulnerability in bikeshed, published on 16 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-23423 and fix it if it is affected.\n\nWhat it is: CVE-2021-23423 is a medium-severity path traversal vulnerability in bikeshed, published on 16 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-23423 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bikeshed (PyPI): affected all versions; fixed in 3.0.0\n- bikeshed (PyPI): affected all versions; fixed in 3.0.0\n- bikeshed (PyPI): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23423/ (Markdown: https://insights.sbomify.com/CVE-2021-23423/index.md)","id":"CVE-2021-23423","markdown":"https://insights.sbomify.com/CVE-2021-23423/index.md","name":"CVE-2021-23423","record":{"aliases":["GHSA-hf6p-4rv2-9qrp","PYSEC-2021-117","SNYK-PYTHON-BIKESHED-1537647","UBUNTU-CVE-2021-23423"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python documentation tool","requires_auth":"none","summary":"An attacker can disclose arbitrary file contents by processing untrusted source files with include directives in the bikeshed documentation tool.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"bikeshed","vendor":"bikeshed_project"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"This affects the package bikeshed before 3.0.0. This can occur when an untrusted source file containing include, include-code or include-raw block is processed. The contents of arbitrary files could be disclosed in the HTML output.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Directory Traversal","id":"CVE-2021-23423","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23424"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"bikeshed","purl":null,"source":"GHSA-hf6p-4rv2-9qrp"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"bikeshed","purl":"pkg:pypi/bikeshed","source":"GHSA-hf6p-4rv2-9qrp"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"bikeshed","purl":"pkg:pypi/bikeshed","source":"PYSEC-2021-117"}],"prev":{"headline":"Arbitrary Code Injection","id":"CVE-2021-23422"},"products":["bikeshed"],"published":"2021-08-16","related":[{"cvss_score":7.8,"headline":"Arbitrary Code Injection","id":"CVE-2021-23422","kev_date_added":null,"published":"2021-08-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can disclose arbitrary file contents by processing untrusted source files with include directives in the bikeshed documentation tool.","url":"https://insights.sbomify.com/CVE-2021-23423/"}