# CVE-2021-23423: Directory Traversal

> An attacker can disclose arbitrary file contents by processing untrusted source files with include directives in the bikeshed documentation tool.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Aug 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-hf6p-4rv2-9qrp, PYSEC-2021-117, SNYK-PYTHON-BIKESHED-1537647, UBUNTU-CVE-2021-23423

## What is CVE-2021-23423?

CVE-2021-23423 is a medium-severity path traversal vulnerability in bikeshed, published on 16 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

This affects the package bikeshed before 3.0.0. This can occur when an untrusted source file containing include, include-code or include-raw block is processed. The contents of arbitrary files could be disclosed in the HTML output.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-23423?

3 open source packages ship an affected version, including bikeshed. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bikeshed` | PyPI | All versions | 3.0.0 |
| `bikeshed` | PyPI | All versions | 3.0.0 |
| `bikeshed` | PyPI | All versions | 3.0.0 |

Products: Bikeshed Project Bikeshed.

## How do I fix CVE-2021-23423?

Upgrade bikeshed to 3.0.0 or later.

## Is CVE-2021-23423 being exploited?

There is no known exploitation of CVE-2021-23423 in the wild and no public exploit code.

## Other vulnerabilities in bikeshed

- [CVE-2021-23422](https://insights.sbomify.com/CVE-2021-23422/): Arbitrary Code Injection (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23423 and fix it if it is affected.

What it is: CVE-2021-23423 is a medium-severity path traversal vulnerability in bikeshed, published on 16 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-23423 in the wild and no public exploit code.

Affected packages and fixed versions:
- bikeshed (PyPI): affected all versions; fixed in 3.0.0
- bikeshed (PyPI): affected all versions; fixed in 3.0.0
- bikeshed (PyPI): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23423/ (Markdown: https://insights.sbomify.com/CVE-2021-23423/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23423
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23423
- OSV: https://osv.dev/vulnerability/CVE-2021-23423

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23423/
Summaries are generated and may contain mistakes; the official description above is the record.
