{"answers":{"affected":"2 open source packages ship an affected version, including ansi-html. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23424 in the wild and no public exploit code.","fix":"Upgrade ansi-html to 0.0.8 or later.","what":"CVE-2021-23424 is a high-severity denial of service vulnerability in ansi-html, published on 18 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23424 and fix it if it is affected.\n\nWhat it is: CVE-2021-23424 is a high-severity denial of service vulnerability in ansi-html, published on 18 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23424 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansi-html (npm): affected all versions; fixed in 0.0.8\n- ansi-html (npm): affected all versions; fixed in 0.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23424/ (Markdown: https://insights.sbomify.com/CVE-2021-23424/index.md)","id":"CVE-2021-23424","markdown":"https://insights.sbomify.com/CVE-2021-23424/index.md","name":"CVE-2021-23424","record":{"aliases":["GHSA-whgm-jr23-g3j9","ROOT-APP-NPM-CVE-2021-23424"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm ansi-html library","requires_auth":"none","summary":"Attackers can cause a denial of service in applications using the ansi-html library by providing malicious input that triggers excessive processing time.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"ansi-html","vendor":"ansi-html_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P","version":"3.1"},"cwes":[],"description":"This affects all versions of package ansi-html. If an attacker provides a malicious string, it will get stuck processing the input for an extremely long time.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23424","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23425"},"packages":[{"ecosystem":"npm","fixed":["0.0.8"],"introduced":["0"],"last_affected":[],"package":"ansi-html","purl":null,"source":"GHSA-whgm-jr23-g3j9"},{"ecosystem":"npm","fixed":["0.0.8"],"introduced":["0"],"last_affected":[],"package":"ansi-html","purl":"pkg:npm/ansi-html","source":"GHSA-whgm-jr23-g3j9"}],"prev":{"headline":"Directory Traversal","id":"CVE-2021-23423"},"products":["ansi-html"],"published":"2021-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can cause a denial of service in applications using the ansi-html library by providing malicious input that triggers excessive processing time.","url":"https://insights.sbomify.com/CVE-2021-23424/"}