# CVE-2021-23424: Regular Expression Denial of Service (ReDoS)

> Attackers can cause a denial of service in applications using the ansi-html library by providing malicious input that triggers excessive processing time.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-whgm-jr23-g3j9, ROOT-APP-NPM-CVE-2021-23424

## What is CVE-2021-23424?

CVE-2021-23424 is a high-severity denial of service vulnerability in ansi-html, published on 18 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects all versions of package ansi-html. If an attacker provides a malicious string, it will get stuck processing the input for an extremely long time.

## Which versions are affected by CVE-2021-23424?

2 open source packages ship an affected version, including ansi-html. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansi-html` | npm | All versions | 0.0.8 |
| `ansi-html` | npm | All versions | 0.0.8 |

Products: Ansi-Html Project Ansi-Html.

## How do I fix CVE-2021-23424?

Upgrade ansi-html to 0.0.8 or later.

## Is CVE-2021-23424 being exploited?

There is no known exploitation of CVE-2021-23424 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23424 and fix it if it is affected.

What it is: CVE-2021-23424 is a high-severity denial of service vulnerability in ansi-html, published on 18 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23424 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansi-html (npm): affected all versions; fixed in 0.0.8
- ansi-html (npm): affected all versions; fixed in 0.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23424/ (Markdown: https://insights.sbomify.com/CVE-2021-23424/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23424
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23424
- OSV: https://osv.dev/vulnerability/CVE-2021-23424

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23424/
Summaries are generated and may contain mistakes; the official description above is the record.
