# CVE-2021-23431: Cross-site Request Forgery (CSRF)

> Attackers can perform unauthorized actions on behalf of users due to missing CSRF checks in Joplin forms.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Aug 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-gjwp-7v3g-99pj, SNYK-JS-JOPLIN-1325537

## What is CVE-2021-23431?

CVE-2021-23431 is a medium-severity vulnerability in joplin, published on 24 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The package joplin before 2.3.2 are vulnerable to Cross-site Request Forgery (CSRF) due to missing CSRF checks in various forms.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-23431?

2 open source packages ship an affected version, including joplin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joplin` | npm | All versions | 2.3.2 |
| `joplin` | npm | All versions | 2.3.2 |

Products: Joplinapp Joplin.

## How do I fix CVE-2021-23431?

Upgrade joplin to 2.3.2 or later.

## Is CVE-2021-23431 being exploited?

There is no known exploitation of CVE-2021-23431 in the wild and no public exploit code.

## Other vulnerabilities in joplin

- [CVE-2022-35131](https://insights.sbomify.com/CVE-2022-35131/): Joplin is vulnerable to arbitrary code execution (critical 9.0)
- [CVE-2026-22810](https://insights.sbomify.com/CVE-2026-22810/): Joplin: Path traversal in OneNote importer allows overwriting arbitrary files (high 8.2)
- [CVE-2022-40277](https://insights.sbomify.com/CVE-2022-40277/): Joplin Remote Code Execution (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23431 and fix it if it is affected.

What it is: CVE-2021-23431 is a medium-severity vulnerability in joplin, published on 24 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-23431 in the wild and no public exploit code.

Affected packages and fixed versions:
- joplin (npm): affected all versions; fixed in 2.3.2
- joplin (npm): affected all versions; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23431/ (Markdown: https://insights.sbomify.com/CVE-2021-23431/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23431
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23431
- OSV: https://osv.dev/vulnerability/CVE-2021-23431

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23431/
Summaries are generated and may contain mistakes; the official description above is the record.
