# CVE-2021-23433: Prototype Pollution

> Prototype pollution in algoliasearch-helper allows attackers to modify object prototypes if arbitrary search patterns are permitted.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-vpf5-82c8-9v36, SNYK-JS-ALGOLIASEARCHHELPER-1570421

## What is CVE-2021-23433?

CVE-2021-23433 is a medium-severity vulnerability in algoliasearch-helper, published on 19 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package algoliasearch-helper before 3.6.2 are vulnerable to Prototype Pollution due to use of the merge function in src/SearchParameters/index.jsSearchParameters._parseNumbers without any protection against prototype properties. Note that this vulnerability is only exploitable if the implementation allows users to define arbitrary search patterns.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2021-23433?

2 open source packages ship an affected version, including algoliasearch-helper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `algoliasearch-helper` | npm | All versions | 3.6.2 |
| `algoliasearch-helper` | npm | All versions | 3.6.2 |

Products: Algolia Algoliasearch-Helper.

## How do I fix CVE-2021-23433?

Upgrade algoliasearch-helper to 3.6.2 or later.

## Is CVE-2021-23433 being exploited?

There is no known exploitation of CVE-2021-23433 in the wild and no public exploit code.

## Other vulnerabilities in algoliasearch-helper

- [CVE-2025-3193](https://insights.sbomify.com/CVE-2025-3193/): algoliasearch-helper is vulnerable to Prototype Pollution in _merge() (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23433 and fix it if it is affected.

What it is: CVE-2021-23433 is a medium-severity vulnerability in algoliasearch-helper, published on 19 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23433 in the wild and no public exploit code.

Affected packages and fixed versions:
- algoliasearch-helper (npm): affected all versions; fixed in 3.6.2
- algoliasearch-helper (npm): affected all versions; fixed in 3.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23433/ (Markdown: https://insights.sbomify.com/CVE-2021-23433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23433
- OSV: https://osv.dev/vulnerability/CVE-2021-23433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23433/
Summaries are generated and may contain mistakes; the official description above is the record.
