{"answers":{"affected":"2 open source packages ship an affected version, including clearance. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23435 in the wild and no public exploit code.","fix":"Upgrade clearance to 2.5.0 or later.","what":"CVE-2021-23435 is a high-severity vulnerability in clearance, published on 12 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-23435 and fix it if it is affected.\n\nWhat it is: CVE-2021-23435 is a high-severity vulnerability in clearance, published on 12 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-23435 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- clearance (RubyGems): affected all versions; fixed in 2.5.0\n- clearance (RubyGems): affected all versions; fixed in 2.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23435/ (Markdown: https://insights.sbomify.com/CVE-2021-23435/index.md)","id":"CVE-2021-23435","markdown":"https://insights.sbomify.com/CVE-2021-23435/index.md","name":"CVE-2021-23435","record":{"aliases":["GHSA-4hpq-rjcx-7vj9","SNYK-RUBY-CLEARANCE-1577284"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby authentication library","requires_auth":"none","summary":"Attackers can redirect users to external domains via manipulated session values in the Clearance Ruby gem, potentially facilitating phishing attacks.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"clearance","vendor":"thoughtbot"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"This affects the package clearance before 2.5.0. The vulnerability can be possible when users are able to set the value of session[:return_to]. If the value used for return_to contains multiple leading slashes (/////example.com) the user ends up being redirected to the external domain that comes after the slashes (http://example.com).","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Open Redirect","id":"CVE-2021-23435","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"open_redirect","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Prototype Pollution","id":"CVE-2021-23436"},"packages":[{"ecosystem":"RubyGems","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"clearance","purl":null,"source":"GHSA-4hpq-rjcx-7vj9"},{"ecosystem":"RubyGems","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"clearance","purl":"pkg:gem/clearance","source":"GHSA-4hpq-rjcx-7vj9"}],"prev":{"headline":"Prototype Pollution","id":"CVE-2021-23434"},"products":["clearance"],"published":"2021-09-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can redirect users to external domains via manipulated session values in the Clearance Ruby gem, potentially facilitating phishing attacks.","url":"https://insights.sbomify.com/CVE-2021-23435/"}