# CVE-2021-23435: Open Redirect

> Attackers can redirect users to external domains via manipulated session values in the Clearance Ruby gem, potentially facilitating phishing attacks.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4hpq-rjcx-7vj9, SNYK-RUBY-CLEARANCE-1577284

## What is CVE-2021-23435?

CVE-2021-23435 is a high-severity vulnerability in clearance, published on 12 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

This affects the package clearance before 2.5.0. The vulnerability can be possible when users are able to set the value of session[:return_to]. If the value used for return_to contains multiple leading slashes (/////example.com) the user ends up being redirected to the external domain that comes after the slashes (http://example.com).

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2021-23435?

2 open source packages ship an affected version, including clearance. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `clearance` | RubyGems | All versions | 2.5.0 |
| `clearance` | RubyGems | All versions | 2.5.0 |

Products: Thoughtbot Clearance.

## How do I fix CVE-2021-23435?

Upgrade clearance to 2.5.0 or later.

## Is CVE-2021-23435 being exploited?

There is no known exploitation of CVE-2021-23435 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23435 and fix it if it is affected.

What it is: CVE-2021-23435 is a high-severity vulnerability in clearance, published on 12 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-23435 in the wild and no public exploit code.

Affected packages and fixed versions:
- clearance (RubyGems): affected all versions; fixed in 2.5.0
- clearance (RubyGems): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23435/ (Markdown: https://insights.sbomify.com/CVE-2021-23435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23435
- OSV: https://osv.dev/vulnerability/CVE-2021-23435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23435/
Summaries are generated and may contain mistakes; the official description above is the record.
