# CVE-2021-23437: Regular Expression Denial of Service (ReDoS)

> Attackers can cause a denial of service in Pillow via a Regular Expression Denial of Service vulnerability in the getrgb function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** ALPINE-CVE-2021-23437, BIT-pillow-2021-23437, DEBIAN-CVE-2021-23437, GHSA-98vv-pw6r-q6q4, MGASA-2021-0448, OESA-2021-1383, PYSEC-2021-317, ROOT-APP-PYPI-CVE-2021-23437, SNYK-PYTHON-PILLOW-1319443, SUSE-SU-2021:3234-1, SUSE-SU-2021:3235-1, UBUNTU-CVE-2021-23437

## What is CVE-2021-23437?

CVE-2021-23437 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2021-23437?

4 open source packages ship an affected version, including pillow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | From 5.2.0 | 8.3.2 |
| `pillow` | PyPI | All versions | 8.3.2 |
| `pillow` | PyPI | From 5.2.0 | 8.3.2 |
| `pillow` | PyPI | From 5.2.0 | 8.3.2 |
| `python-Pillow` | SUSE:HPE Helion OpenStack 8 | All versions | 4.2.1-3.20.2 |
| `python-Pillow` | SUSE:OpenStack Cloud 8 | All versions | 4.2.1-3.20.2 |
| `python-Pillow` | SUSE:OpenStack Cloud 9 | All versions | 5.2.0-3.14.1 |
| `python-Pillow` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.1-3.20.2 |
| `python-Pillow` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 5.2.0-3.14.1 |

Products: Fedoraproject Fedora, Python Pillow.

## How do I fix CVE-2021-23437?

Upgrade pillow to 8.3.2 or later.

## Is CVE-2021-23437 being exploited?

There is no known exploitation of CVE-2021-23437 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23437 and fix it if it is affected.

What it is: CVE-2021-23437 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23437 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected from 5.2.0; fixed in 8.3.2
- pillow (PyPI): affected all versions; fixed in 8.3.2
- pillow (PyPI): affected from 5.2.0; fixed in 8.3.2
- pillow (PyPI): affected from 5.2.0; fixed in 8.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23437/ (Markdown: https://insights.sbomify.com/CVE-2021-23437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23437
- OSV: https://osv.dev/vulnerability/CVE-2021-23437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23437/
Summaries are generated and may contain mistakes; the official description above is the record.
