# CVE-2021-23438: Prototype Pollution

> A type confusion vulnerability in the mpath library allows bypassing previous prototype pollution protections, potentially leading to security feature bypasses.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p92x-r36w-9395

## What is CVE-2021-23438?

CVE-2021-23438 is a medium-severity vulnerability in mpath, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package mpath before 0.8.4. A type confusion vulnerability can lead to a bypass of CVE-2018-16490. In particular, the condition ignoreProperties.indexOf(parts[i]) !== -1 returns -1 if parts[i] is ['__proto__']. This is because the method that has been called if the input is an array is Array.prototype.indexOf() and not String.prototype.indexOf(). They behave differently depending on the type of the input.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2021-23438?

2 open source packages ship an affected version, including mpath. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mpath` | npm | All versions | 0.8.4 |
| `mpath` | npm | All versions | 0.8.4 |

Products: Mpath Project Mpath.

## How do I fix CVE-2021-23438?

Upgrade mpath to 0.8.4 or later.

## Is CVE-2021-23438 being exploited?

There is no known exploitation of CVE-2021-23438 in the wild and no public exploit code.

## Other vulnerabilities in mpath

- [CVE-2018-16490](https://insights.sbomify.com/CVE-2018-16490/): Prototype Pollution in mpath (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23438 and fix it if it is affected.

What it is: CVE-2021-23438 is a medium-severity vulnerability in mpath, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23438 in the wild and no public exploit code.

Affected packages and fixed versions:
- mpath (npm): affected all versions; fixed in 0.8.4
- mpath (npm): affected all versions; fixed in 0.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23438/ (Markdown: https://insights.sbomify.com/CVE-2021-23438/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23438
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23438
- OSV: https://osv.dev/vulnerability/CVE-2021-23438

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23438/
Summaries are generated and may contain mistakes; the official description above is the record.
