# CVE-2021-23440: Prototype Pollution

> Attackers can bypass prototype pollution protections in the set-value library by using array keys, potentially leading to unexpected application behavior.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** AZL-45225, DEBIAN-CVE-2021-23440, GHSA-4jqc-8m5r-9rpr, UBUNTU-CVE-2021-23440

## What is CVE-2021-23440?

CVE-2021-23440 is a high-severity vulnerability in Oracle Communications Cloud Native Core Policy, published on 12 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2021-23440?

8 open source packages ship an affected version, including set-value and set-value-nuget. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `set-value` | npm | All versions | 2.0.1 |
| `set-value` | npm | All versions | 2.0.1 |
| `set-value` | npm | From 3.0.0 | 3.0.3 |
| `set-value` | npm | From 3.0.0 | 3.0.3 |
| `set-value` | npm | From 4.0.0 | 4.0.1 |
| `set-value` | npm | From 4.0.0 | 4.0.1 |
| `set-value-nuget` | NuGet | All versions | 2.0.0 |
| `set-value-nuget` | NuGet | All versions | 2.0.0 |

Products: Oracle Communications Cloud Native Core Policy, Set-Value Project Set-Value.

## How do I fix CVE-2021-23440?

Upgrade set-value to a fixed version for your release line: 2.0.1, 3.0.3 or 4.0.1.

## Is CVE-2021-23440 being exploited?

There is no known exploitation of CVE-2021-23440 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Communications Cloud Native Core Policy

- [CVE-2021-35574](https://insights.sbomify.com/CVE-2021-35574/): Denial of service in Outside In Technology (high 7.5)
- [CVE-2021-22119](https://insights.sbomify.com/CVE-2021-22119/): Resource Exhaustion in Spring Security (high 7.5)
- [CVE-2019-3799](https://insights.sbomify.com/CVE-2019-3799/): Directory Traversal with spring-cloud-config-server (medium 6.5)
- [CVE-2021-33880](https://insights.sbomify.com/CVE-2021-33880/): Observable Timing Discrepancy in aaugustin websockets library (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23440 and fix it if it is affected.

What it is: CVE-2021-23440 is a high-severity vulnerability in Oracle Communications Cloud Native Core Policy, published on 12 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23440 in the wild and no public exploit code.

Affected packages and fixed versions:
- set-value (npm): affected all versions; fixed in 2.0.1
- set-value (npm): affected all versions; fixed in 2.0.1
- set-value (npm): affected from 3.0.0; fixed in 3.0.3
- set-value (npm): affected from 3.0.0; fixed in 3.0.3
- set-value (npm): affected from 4.0.0; fixed in 4.0.1
- set-value (npm): affected from 4.0.0; fixed in 4.0.1
- set-value-nuget (NuGet): affected all versions; fixed in 2.0.0
- set-value-nuget (NuGet): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23440/ (Markdown: https://insights.sbomify.com/CVE-2021-23440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23440
- OSV: https://osv.dev/vulnerability/CVE-2021-23440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23440/
Summaries are generated and may contain mistakes; the official description above is the record.
