# CVE-2021-23442: Prototype Pollution

> Prototype pollution in @cookiex/deep allows attackers to modify global object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L/E:P/RL:O/RC:R`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-92v9-xh2q-fq9f, SNYK-JS-COOKIEXDEEP-1582793

## What is CVE-2021-23442?

CVE-2021-23442 is a high-severity vulnerability in @cookiex/deep, published on 17 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects all versions of package @cookiex/deep. The global proto object can be polluted using the __proto__ object.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2021-23442?

2 open source packages ship an affected version, including @cookiex/deep. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cookiex/deep` | npm | All versions | 0.0.7 |
| `@cookiex/deep` | npm | All versions | 0.0.7 |

Products: Cookiex-Deep Project Cookiex-Deep.

## How do I fix CVE-2021-23442?

Upgrade @cookiex/deep to 0.0.7 or later.

## Is CVE-2021-23442 being exploited?

There is no known exploitation of CVE-2021-23442 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23442 and fix it if it is affected.

What it is: CVE-2021-23442 is a high-severity vulnerability in @cookiex/deep, published on 17 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23442 in the wild and no public exploit code.

Affected packages and fixed versions:
- @cookiex/deep (npm): affected all versions; fixed in 0.0.7
- @cookiex/deep (npm): affected all versions; fixed in 0.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23442/ (Markdown: https://insights.sbomify.com/CVE-2021-23442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23442
- OSV: https://osv.dev/vulnerability/CVE-2021-23442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23442/
Summaries are generated and may contain mistakes; the official description above is the record.
